qtDragon hangs with M6 remap

06 Nov 2023 19:40 - 06 Nov 2023 20:35 #284728 by TMLKyza
It is a pleasure to meet you all even tho I would have preferred it in other circumstances.
Let's start by saying that I love LCNC I just recently built my first CNC machine which is a PrintNC and I wanted to add a tool length sensor.

I'm a complete noob at CNC machines (I just dreamt of having one for years) however I have experience with machining with my grandpa's manual lathe and I daily drive Linux on all my machines (and servers). 

All this to say that adding another sensor to the mix shouldn't be so hard am I right?
How could I've been so wrong. Let's start by saying that I was an AXIS user, and as I have come to realize implementing Versa probe is quite challenging for some reason.

Scowering google the first result that kept popping up is this forum.linuxcnc.org/49-basic-configuratio...with-probe?start=510 and here some guy just kept saying that using qtDragon solves all problems.
I really liked the UI, saw the potential and as such I decided to give it a go.

So I updated my distro and leapt from 2.8.4 to 2.10.
Now that I had the new sample configurations available I decided to merge my AXIS config into sim.qtdragon.qtdragon_tool_probe.
All is well except, I try to dry run some code and after hitting cycle start all it does is go to the G54 position and rise to Z0, then nothing happens and I have to force close qtDragon.
So for the second run, I edited the .ngc file and removed the M6 commands, and now it worked like a charm. So I decided to try and run in MDI T1 M6. Nothing.
This time qtDragon is still responsive and opens up the macro for the tool change. Trying to run it with cycle start, however, does nothing as expected.
Adding the -d and looking at the logs reveals absolutely nothing.

It's been 3 days with my head bashing against this wall and I don't really know what to try next.
I hope someone can help, I am attaching the gcode for both the programs (1001 has the M6 and 1002 does not) and my .ini .hal files plus the logs (I renamed the qtDragon.log to qtdragon-log.txt)

Thanks to everyone in advance!
Last edit: 06 Nov 2023 20:35 by TMLKyza.

Please Log in or Create an account to join the conversation.

07 Nov 2023 03:58 #284747 by cmorley
This line in the printnc.hal needs to be uncommented:

net tool-prepare-loopback iocontrol.0.tool-prepare => iocontrol.0.tool-prepared

Then you should get the manual tool change prompt.

You need to go back to use M6 for toolchanges

let us know if that helps.
The following user(s) said Thank You: TMLKyza

Please Log in or Create an account to join the conversation.

07 Nov 2023 11:43 - 07 Nov 2023 12:05 #284765 by TMLKyza
Well, I'm stupid it was even prescribed in the DOCS, even tho it wasn't that clear if I had to write it in my .hal or in the postgui.hal.

Anyhow, It works now!
However, I feel like I don't really grasp that well how this works.
Let's start by saying that I plan on buying a probe but, currently, I don't have one.
By playing around this morning with the probe screen I think I understood how the workflow should be, feel free to correct me:
first, you load the probe, touch your workpiece in both X Y and Z and report the absolute coordinate for the G54 Z zero into the block height field in Versa probe.
Then with the probe still loaded use the buttons to set the tool length of the probe, so that the tool setter height field gets populated.
And finally, run the program.

That is all and well, however, I don't have a probe, I circumvented the problem by loading the 1st tool for the job and using it as a probe basically by manually zeroing the G54 and copying the ABS value into the block height setting and so on.

But there has to be a better method, I don't really know if I'm doing it right.
I'm doubtful as the measured tool offsets are just huge.

Anyway many thanks again for the already plentiful help!
Last edit: 07 Nov 2023 12:05 by TMLKyza.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.131 seconds
Powered by Kunena Forum