7i90 questions

More
27 Feb 2017 21:45 #88711 by JR1050
Im gonna claim the Chewbacca defense on that one. I missed it, end of the day. It is however in my hal file...to be continued.
Thank you for your help.
More
28 Feb 2017 12:47 - 28 Feb 2017 14:20 #88724 by JR1050
seems to load the drivers

user@CMP-0179:~$ halrun
.
halcmd: halcmd: loadrt hostmot2
<stdin>:1: Unknown command 'halcmd:'
halcmd: loadrt hostmot2
halcmd: loadrt hm2_7i90
halcmd: show pin hm2
Component Pins:
Owner Type Dir Value Name



also tried the same commands at the root account, same results....
Last Edit: 28 Feb 2017 14:20 by JR1050.
More
28 Feb 2017 14:26 #88730 by PCW
Strange.. maybe permissions but I would expect an error

Another thought I had is that this may be the first time someone has used a "JUSTIO" config
so there might be a bug with hostmot2 when no special I/O is present, so it might be worth trying
running with a more standard firmware config
( you can always disable stepgens and pwmgens etc to get a GPIO only config from any firmware )
The following user(s) said Thank You: JR1050
More
28 Feb 2017 14:30 #88731 by JR1050
i switched the justio to 7i90_epp_svst1_4_7i47 yesterday afternoon. Suggestion for a bit file? there is a bunch of them.
More
28 Feb 2017 14:47 #88732 by PCW
If it does not work with one standard EPP config its not likely to make any difference which config you use

What linuxcnc version and OS version are you using? I can see if i can duplicate things here
More
28 Feb 2017 14:50 #88733 by JR1050
debian wheezy from the image on the lcnc downlaod page
Originally 2.7.0, now 2.7.8 as I upgraded an hour ago.
Thank you for all your effort !!
More
28 Feb 2017 20:41 - 28 Feb 2017 20:42 #88776 by PCW
Theres something strange with the hm2_7i90 and hm2_7i43 drivers under halrun

I get the same results with

halrun
halcmd: loadrt hostmot2
halcmd: loadrt hm2_7i90

(no pins)

But if I run a standard hal/ini file set (included here), everything works as expected
so there must be some hal file magic that's different here

File Attachment:

File Name: 7i90.zip
File Size:3 KB
Attachments:
Last Edit: 28 Feb 2017 20:42 by PCW.
More
28 Feb 2017 21:03 #88779 by phillc54
I think I had the same problem and solved it by specifying encoders or stepgens.

Loadrt hm2_7i90 config="num_encoders=-1"
More
28 Feb 2017 21:06 - 28 Feb 2017 21:08 #88780 by PCW
Yep, just figured this out myself, you need a non null config string
even config=" " works but config ="" does not

With a null config string, the driver loads with no complaints but never communicates with the card
( This is true of both EPP drivers: hm2_7i43 and hm2_7i90 )
Last Edit: 28 Feb 2017 21:08 by PCW.
More
28 Feb 2017 22:09 #88783 by JR1050
I eliminated all my configs, built a new hm2 stepper deleted all
the ini and Hal files, copied the contents of the zip and edited it.
It worked. Not an easy one to solve and maybe needs to added to the documentation. Thanks your you help and patience. Next is getting the spi working with the Rpi3.
Moderators: PCWjmelson
Time to create page: 0.167 seconds
Powered by Kunena Forum