Errors preventing LinuxCNC from starting.

07 Sep 2017 19:02 #98638 by cncjohn
cncjohn created the topic: Errors preventing LinuxCNC from starting.
I hope this error log means something to someone. Basically my backup pc is soon going to have a new job as either a plasma machine or a lathe. I dusted it off - went to start it up and encountered a startup issue. I'm fairly sure it used to work a long time back along. Maybe as far back as 3 years. Anyhow here is what it says and I hope someone has solved this before.

Print file information:
LINUXCNC - 2.5.4
Machine configuration directory is '/home/john/linuxcnc/configs/latest-test7-9-17'
Machine configuration file is 'latest-test7-9-17.ini'
Starting LinuxCNC...
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Starting HAL User Interface program: halui
Starting TASK program: milltask
Starting DISPLAY program: axis
Shutting down and cleaning up LinuxCNC...
Killing task linuxcncsvr, PID=1792
Killing task milltask, PID=1840
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments
Cleanup done

Debug file information:
Can not find -sec MOT -var MOT -num 1
Can not find -sec IO -var IO -num 1
Can not find -sec LINUXCNC -var NML_FILE -num 1
Can not find -sec EMC -var NML_FILE -num 1
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 3 (X_GetWindowAttributes)
Resource id in failed request: 0xffffffff
Serial number of failed request: 721
Current serial number in output stream: 722
Stopping realtime threads
Unloading hal components

Kernel message information:
[ 199.582290] I-pipe: Domain RTAI registered.
[ 199.582303] RTAI[hal]: <3.8.1> mounted over IPIPE-NOTHREADS 2.6-03.
[ 199.582306] RTAI[hal]: compiled with gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) .
[ 199.582314] PIPELINE layers:
[ 199.582317] f8ee4e20 9ac15d93 RTAI 200
[ 199.582320] c085cb20 0 Linux 100
[ 199.605922] RTAI[malloc]: global heap size = 2097152 bytes, <BSD>.
[ 199.606095] RTAI[sched]: IMMEDIATE, MP, USER/KERNEL SPACE: <with RTAI OWN KTASKs>, kstacks pool size = 524288 bytes.
[ 199.606099] RTAI[sched]: hard timer type/freq = APIC/12557625(Hz); default timing: periodic; linear timed lists.
[ 199.606103] RTAI[sched]: Linux timer freq = 250 (Hz), TimeBase freq = 2009349000 hz.
[ 199.606106] RTAI[sched]: timer setup = 999 ns, resched latency = 2943 ns.
[ 199.606223] RTAI[usi]: enabled.
[ 199.683277] RTAI[math]: loaded.
[ 199.818698] config string '0x378 out '
[ 202.244806] RTAI[math]: unloaded.
[ 202.301472] SCHED releases registered named ALIEN RTGLBH
[ 202.316866] RTAI[malloc]: unloaded.
[ 202.416013] RTAI[sched]: unloaded (forced hard/soft/hard transitions: traps 0, syscalls 0).
[ 202.419537] I-pipe: Domain RTAI unregistered.
[ 202.419547] RTAI[hal]: unmounted.
08 Sep 2017 14:58 #98695 by andypugh
andypugh replied the topic: Errors preventing LinuxCNC from starting.
This looks like an OpenGL problem.
As an experiment, change the [DISPLAY] section to use tklinuxcnc rather than Axis.
11 Sep 2017 14:53 #98836 by cintsa cnc
cintsa cnc replied the topic: Errors preventing LinuxCNC from starting.
I am experiencing the same problem. I have tried switching to tklinuxcnc but no change. Can you advise what I need to do to get the resultant error report into print like the one above.
12 Sep 2017 08:38 #98867 by cintsa cnc
cintsa cnc replied the topic: Errors preventing LinuxCNC from starting.
In the debug section I have noticed a line that says "cant find module hm2_eth in /usr/realtime -3.4-9-rtai- 686 - pae/modules/linuxcnc-0921.

Can this be the problem as it also says
stopping realtime threads
unloading hal components
12 Sep 2017 13:45 #98890 by PCW
PCW replied the topic: Errors preventing LinuxCNC from starting.
Yep that's the problem.

You cannot run hm2_eth under with a RTAI kernel ( it needs a Preempt-RT kernel and the uspace version of LinuxCNC )

The easiest way to do this currently is by installing the new Debian Stretch + LinuxCNC uspace test ISO:
The following user(s) said Thank You: cintsa cnc
18 Sep 2017 06:40 #99076 by cintsa cnc
cintsa cnc replied the topic: Errors preventing LinuxCNC from starting.
I loaded the program via a usb stick.
During the install it asked for a suitable MIRROR. I tried just about every country and site mentioned but none allowed the install to proceed. Not sure what a MIRROR is and why it is needed

I then tried running the first option which worked fine and and found all the 7176e features.
Problem is nothing gets saved so the config will have to be run every time unless I get the install to work proprly.
The the Ethernet connection is not being found and is terminated a fter a long search.

Could the Ethernet address be different to what the program is looking for. Please give command line to find Ethernet address
18 Sep 2017 17:54 #99094 by andypugh
andypugh replied the topic: Errors preventing LinuxCNC from starting.
It seem that the installer was looking for a site from which to download some patches / updates during the install process.
Was there a network available to it at the time? Clearly it will need to be able to connect to the internet if it is to make use of an of the mirror servers. (Mirror servers just hold exactly the same data as the main server, to share server load)
18 Sep 2017 18:54 #99096 by cintsa cnc
cintsa cnc replied the topic: Errors preventing LinuxCNC from starting.
There was no internet connection at the time because I was unable to get it to connect to my wireless net work. It kept coming back with an error message asking for the password which it would not accept.
Time to create page: 0.105 seconds
Powered by Kunena Forum