Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.

More
25 Jul 2017 16:35 #96398 by tecno
tecno created the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
At last I have managed to connect all in my mill and I have powered up and no issues there (no fires no breakers ;) )
.
Did run PNCCONF for X-Y-Z-A with ruff figures so I can get .hal and .ini written as a base.

Shortcut to start only shows 'splash' screen and nothing happens, so now I need som hints on 'how-to' get things going.

Cheers
Bengt
More
25 Jul 2017 18:58 #96409 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
In PNCCONF there are I/O connector 1, 2 and 3 = what are these on the 7i76E board?

Cannot wrap my head around numbers 017 to 050 what they are on the board.
More
25 Jul 2017 19:00 #96410 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
TB6, why can I not have 2 probe inputs?
More
25 Jul 2017 19:07 #96411 by PCW
PCW replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
GPIO 17 through 50 are the expansion connector GPIO pins (7I76e manual page 7)

You can have as many probe inputs as you like but I dont think PNCConf knows how to configure them
(you would need a method to select the active input)
More
25 Jul 2017 19:17 #96412 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
OK, so I just let those be. Will use Digital in on the other probe.


How do I get the *Launch test panel* to work? How do I know my PC is connected to 7i76E?
More
25 Jul 2017 19:37 #96413 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
7i73 is also a mystery to setup in PNCCONF.

How do I set it up to mode 1 = no keys no LCD

P1 pins 11-18 need to be inputs
P2 pins 14/15 to dedicated MPG encoder input
More
25 Jul 2017 20:03 - 25 Jul 2017 20:16 #96416 by tecno
tecno replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Here my INI and HAL so far + my spreadsheets with I/O wanted

File Attachment:

File Name: combimill.hal
File Size:16 KB

File Attachment:

File Name: combimill.ini
File Size:5 KB


File Attachment:

File Name: MESA7i73_2...7-25.pdf
File Size:22 KB

File Attachment:

File Name: MESA7i76EC...mill.pdf
File Size:24 KB

File Attachment:

File Name: MESA7i85SC...mill.pdf
File Size:16 KB
Last Edit: 25 Jul 2017 20:16 by tecno.
More
26 Jul 2017 03:09 #96442 by rodw
rodw replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
Have you seen this?
forum.linuxcnc.org/27-driver-boards/3191...n-sheet?limitstart=0

Grab the updated document after a request of mine. I think its at the bottom of page 1.

This is very good
The following user(s) said Thank You: tecno
More
26 Jul 2017 03:10 #96443 by rodw
rodw replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
And I never got the test panel working. I just did everything by hand.
More
26 Jul 2017 04:59 #96446 by rodw
rodw replied the topic: Help needed to get my 7i76E + 7i85S + 7i73 on my mill going.
I had a look at your files. You should not be using P1 and P2 at all for what you are doing. If you are trying to retain your breakout boards you are loosing so many benefits the 7i76e has to offer. You

File Attachment:

File Name: DesignNote...tter.pdf
File Size:83 KB
are far better off starting from scratch. Use the stepgens on TB2 and the field inputs and outputs outputs on TB5 & TB6

I've attached my design notes (7i76e pinouts start on Page 4) which when read in conjunction with the connection sheet might help. Note I've coloured in some pins which in a perfect world should be moved off the analog to digital converters (but I'll probably never bother)
Attachments:
Moderators: cmorley
Time to create page: 0.084 seconds
Powered by Kunena Forum