Servo Setup

More
28 Sep 2012 14:01 - 28 Sep 2012 14:02 #24689 by Todd Zuercher
Servo Setup was created by Todd Zuercher
Is there a rule of thum as to how to set the max acceleration with servos? In other words for the analog signal to the amp how much headroom should I leave. Obviously I don't want a move to use 100%. But what should be an acceptible number 30.50,75%...?
Last edit: 28 Sep 2012 14:02 by Todd Zuercher.

Please Log in or Create an account to join the conversation.

More
28 Sep 2012 14:14 #24690 by andypugh
Replied by andypugh on topic Re:Servo Setup
Todd Zuercher wrote:

Is there a rule of thum as to how to set the max acceleration with servos?


As high as you can without following errors, I think.

You probably need to experiment with the maximum load expected.

Please Log in or Create an account to join the conversation.

More
28 Sep 2012 14:36 #24691 by PCW
Replied by PCW on topic Re:Servo Setup
Yes, you need headroom for cutting load and friction.
so that you do not use all of the available torque just for acceleration.

What type of load do you have? for non cutting machine 80% might be OK

Please Log in or Create an account to join the conversation.

More
28 Sep 2012 15:31 #24693 by Todd Zuercher
Replied by Todd Zuercher on topic Re:Servo Setup
It is a wood router that is used for 2.5D and 3D carving and engraving. So I don't think the loads are huge. I was thinking of cranking up the accel untill I see peaks of about 50% and see how that works. I am still a ways from actually cutting something. One of my servos is giving me issues that I need to straighten out first before I can actually cut something.

PS. Who ever said you were more than 50% likely to have a run-a-way the first time you hook up a servo. Guess I'm just lucky. Asside from these encoder error drive shutdowns this has been surprisingly uneventful. Of couse I did preliminary bench testing before going to the machine and got the ugly run-a-way bugs out there ;)

Please Log in or Create an account to join the conversation.

More
29 Sep 2012 03:19 #24706 by jmelson
Replied by jmelson on topic Re:Servo Setup
Todd Zuercher wrote:

Is there a rule of thum as to how to set the max acceleration with servos? In other words for the analog signal to the amp how much headroom should I leave. Obviously I don't want a move to use 100%. But what should be an acceptible number 30.50,75%...?

Given a fixed current limit on the servo amp, you can use Halscope to observe the
drive hitting the current limit. Increase the acceleration limit and at some point you
will see the following error suddenly diverge. I really don't know what a reasonable
setting would be once you find the real physical limit. I think acceleration is one of
the largest demands on a machine tool, though, so you probably don't have to
leave a huge margin.

Jon

Please Log in or Create an account to join the conversation.

Time to create page: 0.133 seconds
Powered by Kunena Forum