Velocity 5axis

More
06 Feb 2013 00:39 #29651 by Mr_Wolfs
Velocity 5axis was created by Mr_Wolfs
Hello,

I built a 5 axis machine, all works but I have a problem with the velocity.
When I'm in world mode (teleop) the Z axis take the velocity of the MAX_LINEAR_VELOCITY in the [TRAJ] section.


Have you got an idea?
I post here the .hal config and here the .ini of my machine.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 02:09 #29660 by andypugh
Replied by andypugh on topic Velocity 5axis

I built a 5 axis machine, all works but I have a problem with the velocity.
When I'm in world mode (teleop) the Z axis take the velocity of the MAX_LINEAR_VELOCITY in the [TRAJ] section.


That is what that entry means.
You need to choose a value that suits the slowest axis.
Then any linear move in any direction can be achieved at the programmed rate, up to that limit.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 02:16 #29661 by Mr_Wolfs
Replied by Mr_Wolfs on topic Velocity 5axis
Then you say me that I must put MAX_VELOCITY = 10 to all linear axis.

It's bad I could go faster with my machine.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 02:28 #29664 by andypugh
Replied by andypugh on topic Velocity 5axis

Then you say me that I must put MAX_VELOCITY = 10 to all linear axis.

It's bad I could go faster with my machine.


No, you can use the maximum velocity in the indvidual axis sections, and that will be the velocity used in joint-mode moves.

However in world mode there is only one maximum speed, and that is governed by the speed of the slowest axis. This is a consequence of how the velocity limiitation is done.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 02:41 - 06 Feb 2013 02:42 #29665 by Mr_Wolfs
Replied by Mr_Wolfs on topic Velocity 5axis
ok but it's strange cause when I start a gcode, the Z axis move faster than in joint-mode.

the tool path doesn't follow the good trajectory.

We can't change the velocity limitation in world mode?
Last edit: 06 Feb 2013 02:42 by Mr_Wolfs.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 02:54 #29666 by andypugh
Replied by andypugh on topic Velocity 5axis

ok but it's strange cause when I start a gcode, the Z axis move faster than in joint-mode.

That is strange.
I wonder if it related to the fact that you have a STEPGEN_MAXVEL defined for the Z axis, but not for any other?

We can't change the velocity limitation in world mode?

I am not at all familiar with 5axiskins.
Bear in mind that it will try to make the tool tip follow the programmed path, and if the tool length is wrong or the 5axiskins offsets are wrong then the resulting path will be wrong.

Please Log in or Create an account to join the conversation.

More
06 Feb 2013 16:25 #29691 by Mr_Wolfs
Replied by Mr_Wolfs on topic Velocity 5axis
No the STEGEN_MAXVEL defined for the Z axis was a test but I can't see the difference with it.

My 5axiskins is set up correctly I have the good tool length for my machine.

Please Log in or Create an account to join the conversation.

More
07 Feb 2013 04:56 #29733 by andypugh
Replied by andypugh on topic Velocity 5axis

No the STEGEN_MAXVEL defined for the Z axis was a test but I can't see the difference with it.
My 5axiskins is set up correctly I have the good tool length for my machine.


I am afraid that I have reached the limit of my knowledge with 5axiskins.
You might find better help on the mailing list of the IRC channel.
See the "Community" link at the top.

Please Log in or Create an account to join the conversation.

More
07 Feb 2013 05:30 #29737 by Mr_Wolfs
Replied by Mr_Wolfs on topic Velocity 5axis
It's not a problem thanks for your help

Please Log in or Create an account to join the conversation.

More
13 Feb 2013 06:59 #29988 by Mr_Wolfs
Replied by Mr_Wolfs on topic Velocity 5axis


We can see that the velocity is better than in the file .ini

Please Log in or Create an account to join the conversation.

Time to create page: 0.150 seconds
Powered by Kunena Forum