Sanyo Denki Servos with MESA 5i25+7i76 Config

More
07 Mar 2013 14:14 #31013 by DonnyM
Ok found something I had not found before. Its why my limits were not working. I know you told me to look there but I just did not follow. Sorry

I went to hm2_5i25/0/7i76/0/0 and there is all my outputs and inputs.
and yes the input 0-2 works correctly with my limit switches. Now I just have to edit the HAL correctly to see this correctly.

Now what about my motors What do I need to do to the HAL file to get those working?


thanks,
Donny

Please Log in or Create an account to join the conversation.

More
07 Mar 2013 14:32 #31014 by DonnyM
I edited my HAL file and now my limits works as they should. thanks for helping find my way there. I never correlated the relation between hm2_5i25.0.7i76.00 etc as the actual path in the tree. Makes me feel real stupid. Sorry it took me so long to get it.
Now any ideas on how I get my motors working.

Donny
The following user(s) said Thank You: 3kamalakkannan

Please Log in or Create an account to join the conversation.

More
07 Mar 2013 23:11 #31038 by PCW
I would think you should be getting step pulses by jogging at this point so things to verify:

Correct step wiring (at least 5 wires per axis CW+,CW-,GND,CCW+,CCW-)

Drive is enabled (real drives always have a drive enable input signal)

Drive firmware is setup to accept CW/CCW command signals

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum