Manual Control

More
28 Jun 2010 18:22 #3236 by Pentax
Manual Control was created by Pentax
So, I've been using the EMC machine as a cnc for quite sometime, and its great, and flawless. However, i would like to be able to use it as a just a DRO that can be used to set a zero, etc, for people who don't have cnc skills. Currently, the ability to set zero while the machine is off, is not an option. I have my machine off button spliced between a GPIO pin that takes care of EMC, and a wire that remotely turns off my servo amps.

I found in the database a command AXIS_NO_AUTOCONFIGURE, which i assume would be the answer to my problem. However, the literature says use the environment variable AXIS_NO......

My question is. what the heck is an environment variable and where does it go? The ini file seems most intuitive, as it seems inappropriate for the hal file. I saw some stuff on the web site about developers and shell mods, which seems way over my head. Is there a way i can use this command?

Thanks,
A

Please Log in or Create an account to join the conversation.

More
28 Jun 2010 22:20 #3239 by BigJohnT
Replied by BigJohnT on topic Re:Manual Control
My first thought is to make a second config for manual use just to get a dro.

I have no idea what AXIS_NO_AUTOCONFIGURE is...

John

Please Log in or Create an account to join the conversation.

More
28 Jun 2010 22:44 #3240 by BigJohnT
Replied by BigJohnT on topic Re:Manual Control
and here is what AXIS_NO_AUTOCONFIGURE is... from the EMC IRC channel.

[17:16] <JT-Hardinge> anyone know what AXIS_NO_AUTOCONFIGURE is for?
[17:24] <jepler> JT-Hardinge: Normally, AXIS removes widgets which correspond to machine features that don't seem to exist
[17:25] <jepler> JT-Hardinge: for instance, if AXIS doesn't detect a spindle brake, then the "spindle brake" button is removed from the Manual tab
[17:25] <jepler> if the environment variable (*not* inifile variable) AXIS_NO_AUTOCONFIG is set to a non-empty value, then AXIS doesn't do this, and all those widgets will appear

John

Please Log in or Create an account to join the conversation.

More
29 Jun 2010 16:54 #3245 by Pentax
Replied by Pentax on topic Re:Manual Control
ok, well. how would you propose I go about doing this? it seems that if the machine is on, but the servos turned off, then it still won't zero. is this all an axis thing? maybe i should use another interface.....

A

Please Log in or Create an account to join the conversation.

More
29 Jun 2010 18:34 #3246 by BigJohnT
Replied by BigJohnT on topic Re:Manual Control
If you want to home just turn the machine on and home it then click on the e-stop and you can crank the handles all you want and the DRO will work.

John

Please Log in or Create an account to join the conversation.

More
29 Jun 2010 18:55 - 29 Jun 2010 18:58 #3247 by Pentax
Replied by Pentax on topic Re:Manual Control
and still be able to set zero? i tried that and I am still not able to use the zero button or press the end key with an axis. thats why i leaned toward the command mentioned earlier, i hope it would bring those buttons back that would otherwise be unavailable....
Last edit: 29 Jun 2010 18:58 by Pentax.

Please Log in or Create an account to join the conversation.

More
29 Jun 2010 19:07 #3248 by BigJohnT
Replied by BigJohnT on topic Re:Manual Control
I knew there was more than meets the eye here... Doesn't look like it allows you to set offsets when run is not selected in Axis. You might try some of the other interfaces or ask on the IRC emc channel.

John

Please Log in or Create an account to join the conversation.

Time to create page: 0.069 seconds
Powered by Kunena Forum