Strange Joint Axis Homing regression

More
17 Jul 2017 13:54 - 17 Jul 2017 13:55 #95893 by rodw
rodw created the topic: Strange Joint Axis Homing regression
HI guys, this is pretty strange.

I had my JA gantry machine working perfectly so it was time to tidy up all of the temporary wires and put connectors on my control box.

Now my Joint Axis won't home. One side just ignores the home switch and continues until it hits a hard limit. All limit and home switches are PNP NC proximity sensors and I'm using input-xx-not as the inputs. When it crashes to a stop, the home switch on that side is still activated.

Ok, I must have got the wiring wrong when I inserted a DB9 into the cable that was previously hardwired.

But I've traced every wire back to the Mesa 7i76e inputs and checked continuity all of the way on every wire. And I've checked the results in halshow when I trigger the proximity sensors. I've also confirmed the sensors are turning on inputs at the 7i76e with a multimeter. Everything works perfectly.

Because it worked and then stopped working after I changed the wiring around, everything points to a wiring fault but I am at a loss to explain what it could be. I've attached my hal and ini files just in case.

Anyway, If anybody has some ideas regarding troubleshooting methods it would be really appreciated as I am absolutely stumped!

File Attachment:

File Name: Spaceship_..._PID.ini
File Size:7 KB

File Attachment:

File Name: Spaceship_...7-17.hal
File Size:21 KB
Attachments:
Last Edit: 17 Jul 2017 13:55 by rodw.
More
17 Jul 2017 14:07 #95894 by Todd Zuercher
Todd Zuercher replied the topic: Strange Joint Axis Homing regression
Use halmeter to check to see that Linuxcnc is seeing the inputs for your home switches turning on/off as expected.

If that is working, then check your hal connections, and finally your ini settings. Things like this are hard to diagnose remotely.
More
17 Jul 2017 14:20 #95897 by rodw
rodw replied the topic: Strange Joint Axis Homing regression
Thanks Todd, thats basically what I've done but I've used Halshow so I can put all of the signals on one watch page.

I thought I'd get a mate over to work through it with me but he knows nothing about LCNC.

Any other troubleshooting ideas?
More
17 Jul 2017 14:52 #95899 by rodw
rodw replied the topic: Strange Joint Axis Homing regression
Hm, I just had a thought. My home switches stay triggered until a hard limit is reached. Could it be possible that the directions have somehow got mixed up and LCNC sees the home switch but goes the wrong way when it backs off so continues until it crashes?

Maybe I swapped steppers from one side to the other or something silly.
More
17 Jul 2017 14:58 #95900 by Todd Zuercher
Todd Zuercher replied the topic: Strange Joint Axis Homing regression
Which joints are working and which are not? I see in you hal file that joints 0&1 are using -not inputs but 2&3 use the normal inputs. Is this correct?

Make sure that each switch triggers the correct input, by manually triggering each switch individually while watching them with Halmeter (or the watch page in Halshow). (Make sure you didn't cross any wires.) Also make sure you get the correct readings when triggering both switches (that Joint0 home toggles on and off while Joint1 is on or off and vice versa).
More
17 Jul 2017 15:00 #95901 by Todd Zuercher
Todd Zuercher replied the topic: Strange Joint Axis Homing regression
Yes that is possible, but you likely would have noticed them going the wrong way before the home was triggered, unless they were already on the home switches.
More
17 Jul 2017 20:43 #95940 by rodw
rodw replied the topic: Strange Joint Axis Homing regression
Todd,
Thanks, I'll have a look this evening. It was parked at/near the max limits while I spent 2 days tidying up the wires.

Yes my joint axis is on joints 0 and 1

I do remember I got some surprises with motion the first time I tried to jog the JA. Now I can't remember what I did other than deleting the Linuxcnc.var file which from experience gets out of step.

What I suggested seems to be the only rational explanation so at least I have a next step to try.
More
20 Jul 2017 03:08 #96119 by rodw
rodw replied the topic: Strange Joint Axis Homing regression
Well, after wasting a few days on this, double checking all of the wiring and everything, I slowed down the homing velocities and realised the problem was the home switches were inverted. A quick edit of the HAL file got it running again.

But then I had to work out why this had happened because if the home signal was wrong, the limits would be too. I finally worked out that I had inadvertently swapped the 5 volt step/dir connectors on the stepper drivers around when I was rewiring.so while the sensors remained the same, the stepgens for joint 0 and 1 were the wrong way round. Sure enough swapping the plugs around and restoring the HAL file to the way it was, solved it perfectly.
Time to create page: 0.069 seconds
Powered by Kunena Forum