× Forum Header

Configuration of a HAASE CUT 2500

More
21 Jan 2015 18:59 #55235 by Promme
Hi,

I post here a configuration of a haase CNC 2500 profi as a future reference. It does not accept standard settings since it requires an additional latch clock signal which I have generated and routed to pin 16. The magic lines to be added to custom.hal were
loadrt siggen
setp siggen.0.frequency 12500 
# note: servo-thread is too slow for this frequency
addf siggen.0.update servo-thread 
# will run with a period of 1ms instead of 80us
net cnc-latch siggen.0.clock => parport.0.pin-16-out

it runs on linuxCNC 2.5. Additionally a USB camera is used (PCE-MM200 Microscope) according to wiki.linuxcnc.org/cgi-bin/wiki.pl?Axis_Embed_Video

Stepping is very smooth in contrast to the shitty USB-LPT box solution which was provided together with the table.

Thank you for this very nice distribution!
Attachments:
More
11 Sep 2018 08:26 #117322 by florian
Hey all,

I'm currently trying to get a HAASE CUT2500 to run with LinuxCNC 2.7.
I downloaded the configuration provided by Promme and removed the "probe_parport" driver from the hal file as this is no longer needed for the new version.
Checking with an oscilloscope, everything seems to work (x/y/z dir, x/y/z step, ...) except the latch signal Promme describes in his post.
Although my custom.hal looks exactly the same and this file is loaded when starting LinuxCNC, it does not work.
When starting the programm Pin16 shows only one tact. It goes high and 1ms later its low and stays low. Were there any changes between the versions of LinuxCNC that could explain this behavior? I'm new to LinuxCNC but reading the HAL documentation I could not find reason why this is not working...

Without the latch signal on pin16, the CNC machine does absolutely nothing.

Any help appreciated!
More
11 Sep 2018 14:40 #117338 by florian
Problem solved. Updating the output of a 12.5 kHz signal with 1 kHz (Servo-thread) doesn't seem to be a good idea.... I reduced siggen.0.frequency to 500 and now it works!
Time to create page: 0.057 seconds
Powered by Kunena Forum