× Forum Header

need help with pitch calibration

More
04 May 2016 02:37 #74208 by Bradmillikan
Bradmillikan created the topic: need help with pitch calibration
Hi all,
Im new here and have searched for an answer but cant seem to figure this one out. So here goes. When I setup my machine in stepconf I can't get the axis to travel the right distance. I have nema 23 motors with 1.8 dgrees 200 steps. Im using st-m5045 drivers. The driver is set to move in half steps which gives me 400 pulses. Im also using a 1/4" by 20 lead screw at .05 pitch. The following is my setup.


Motor steps per revolution 400 ( I have used 200 )
Driver Microstepping 2
Pulley teeth 1:1 ( no pulley)
Lead screw pitch .05 (1/4"-20 rod)

Everything runs smooth I just cant get it calibrated properly . I can change the pitch and gear ratio around and can get close to moving the actual measured distance but I should be able to get it work by just putting in the numbers. Any help would be greatly appreciated.

Thanks
Brad
More
04 May 2016 10:46 #74214 by andypugh
andypugh replied the topic: need help with pitch calibration
It should work with 200 steps / x2 microstepping and 0.05 pitch.

If you are not a simple factor of 2 out then something else is going on.

Are you 100% sure that your screw is not M6 x 1 ? (ie 25.4 tpi, 0.03937" pitch)

Does the error change if you halve the speed and accel numbers? Is it possible that a coupling is slipping?
More
04 May 2016 19:51 #74243 by Bradmillikan
Bradmillikan replied the topic: need help with pitch calibration
So my lead screw is for sure 1/4"-20. Pitch should be .05. I did some research after posting on forum. I know for sure that these settings are right and even tried them on Mach 3. The total steps should be 8000 per inch. What's happening now though, I test it to move .5 inch it's actually 1 inch. Spot on. So I changed microstep to 1. Now it's exact but my total is half at 4000 per in. It should t be this way. The math works out to 8000. I added a snapshot of the stepconf from Linuxcnc manual. My setup is exact. Like I said though I have to change microstep to one to make it work.
Attachments:
More
04 May 2016 21:17 #74245 by andypugh
andypugh replied the topic: need help with pitch calibration
What number do you end up with in the INI file when it is working properly?
More
05 May 2016 00:50 #74250 by Bradmillikan
Bradmillikan replied the topic: need help with pitch calibration
I am using 1 for micro step so 4000 is what it shows. If I change that to two it goes to 8000.
More
05 May 2016 09:24 #74258 by cncbasher
cncbasher replied the topic: need help with pitch calibration
you dont mention what stepper drivers you are using ? some default to Half step as minium
the figure that matters is the final scale value in each axis in your ini file , not what you enter into stepconfig
i'll guess it's more to do with your drivers , just leave them at half step and enter the scale value in your ini file by hand
so long as it moves the correct distance your fine .
More
05 May 2016 16:30 #74280 by Bradmillikan
Bradmillikan replied the topic: need help with pitch calibration
st-m5045 Driver by sainsmart
Set at 2 microsteps=1/2 steps at 400 pulses

All settings in ini file are same as stepconf.

The thing I'm stumped about is that these same settings work in mach3.
More
10 May 2016 03:33 #74430 by Bradmillikan
Bradmillikan replied the topic: need help with pitch calibration
So I finally have this one figured out. I thought I would post it so I can maybe help someone else in the future. So when I put all my settings in stepconf and test in stepconf the actual scale is doubled when I measure it. The ini file is exact settings. So I finally gave it a whirl in linuxcnc and what do you know it all works out right with the scale. So the problem is with stepconf , it doubles when it runs. It sets it up fine in ini file . So you have to actual test your results in Linux Cnc , the stepconf file is useless for testing for acurracy.

Thanks for your posts and help, I hope someone finds this usefull
More
11 Nov 2016 19:56 #82706 by SenorAguas
SenorAguas replied the topic: need help with pitch calibration
I noticed this, as well, just yesterday, when I hooked up a dial indicator/mag base and tried to verify my calibration in stepconf.
Time to create page: 0.074 seconds
Powered by Kunena Forum