× Forum Header

E-Stop Enabled but Does Not Respond

More
18 Oct 2016 15:48 #81794 by miketim
miketim created the topic: E-Stop Enabled but Does Not Respond
Guys, this is my first post, please correct me if need be.
I've configured LinuxCNC for Syil X5 Speedmaster (a small CNC mill).

After setting up the pins and testing the XYZ axis, all looked good: axis did move correctly.

As soon as I fire up the LinuxCNC Axis GUI, the 'E-Stop toggle button' on the GUI remains pressed and the 'Power button' is disabled.

What trouble shooting steps would you recommend?

Many thanks!
Michael
More
18 Oct 2016 16:01 #81795 by andypugh
andypugh replied the topic: E-Stop Enabled but Does Not Respond
Can you post your HAL file? It is probably the e-stop loop in there.
More
18 Oct 2016 16:05 #81796 by Todd Zuercher
Todd Zuercher replied the topic: E-Stop Enabled but Does Not Respond
Does your machine use the e-stop or power connections?

If your config is not useing those connections the e-stop pins still need to be looped back to them selves in the software.
I think examples of this can be found in some of the sample simulation configs. (or used to be before they were all switched to hal.tcl files.)
More
18 Oct 2016 16:09 #81797 by tommylight
tommylight replied the topic: E-Stop Enabled but Does Not Respond
Or when making the config, do not set any of the input pins as e-stop.
More
18 Oct 2016 17:43 #81802 by miketim
miketim replied the topic: E-Stop Enabled but Does Not Respond
I'll post the HAL file this evening - I am not at the machine right now. Thanks!
More
18 Oct 2016 17:48 #81803 by miketim
miketim replied the topic: E-Stop Enabled but Does Not Respond
The machine has e-stop button (physical) and also has connection on the breakout board for e-stop.
The Mach3 e-stop software button worked fine. So I assume I screwed up somewhere with the setup.

I did configure one of the pins as e-stop out, but not sure if it's the right one (am I good or what).

Also I configured a correct input pin for e-stop as well.
More
18 Oct 2016 22:41 #81811 by miketim
miketim replied the topic: E-Stop Enabled but Does Not Respond
Here's the HAL file for my config.
I am still learning so it still is not really clear to me.
Thanks for all your help!

File Attachment:

File Name: my-mill1.hal
File Size:3 KB
Attachments:
More
18 Oct 2016 23:06 #81812 by andypugh
andypugh replied the topic: E-Stop Enabled but Does Not Respond
It looks like you need to change the state of parallel port pin 11. What is that wired to?

You could try inverting the sense of pin 11 if it is wired up and you are happy with the circuit.

Change
net estop-ext       <= parport.0.pin-11-in
to
net estop-ext       <= parport.0.pin-11-in-not

linuxcnc.org/docs/2.7/html/hal/parallel-port.html
More
19 Oct 2016 12:13 #81838 by miketim
miketim replied the topic: E-Stop Enabled but Does Not Respond
Awesome, it worked! Thanks so much!
The axis speeds are soooo slow though.
In calibration dialog I increased the scale from 4000 to 100000. Then the axis started moving faster.
I am not sure if that's the right way to adjust the speeds, though.

How would you do it guys?
More
19 Oct 2016 12:29 - 19 Oct 2016 12:32 #81839 by Todd Zuercher
Todd Zuercher replied the topic: E-Stop Enabled but Does Not Respond
That isn't normally the right way to change speeds, because it also changes the distance moved. The max velocities for your config is set in several places in your ini file. In the [TRAJ], [AXIS_n], and [JOINT_n] (if you are using Master). Look for MAX_VELOCITY and STEPGEN_MAXVEL
linuxcnc.org/docs/html/config/ini-config.html

Remember the numbers for these settings are in machine units / SECOND, not per minute. So they will be inches/sec or mm/sec. If you input them as /min you should multiply them by 60.
Last Edit: 19 Oct 2016 12:32 by Todd Zuercher.
Time to create page: 0.075 seconds
Powered by Kunena Forum