× Forum Header

Home switches not "seen" by linuxCNC

19 Apr 2017 23:27 - 19 Apr 2017 23:30 #91681 by MAG45
I have been working on rebuilding my CNC'd 3 in 1 that a friend built me years ago. I have most everything working again but Home Switches. I have a CNC4PC C-10 BoB and my switches are wired NC in series to pin 12 (also tried 11) just as shown in the C-10's manual. I have tested continuity and function of the switches at the wires that connect to the BoB and they are functioning as they are intended. It seems no matter what i try in stepconfig wizard that LinuxCNC just doesnt see the connection. Any ideas of what I can try or a way to see if the signal is getting back to Linux?

Also, I am completely lost in the Linux O.S. if a have to install a tool or something I will need a step by step. Im learning, but its a slow curve.
Last edit: 19 Apr 2017 23:30 by MAG45.
20 Apr 2017 23:58 #91739 by MAG45
Got the ptest paralell port test working. No matter which input i connect my home switches to i get no feedback. Strange that the Estop does work properly and its on the same input rail. Testing continuity at the wires from the limits that would connect to the BoB shows closed normally, and open when i press any one of the switches. I swapped to a new cable from the PC to the BoB and no change. I tried to add a dual P-port card i had but could not figure out how to get linux to recognize it.
21 Apr 2017 00:04 #91740 by bevins
Build your basic setup in stepconfig and dont look back.

Get into the hal file and tweak from there.

Just a thought

21 Apr 2017 00:17 #91741 by MAG45

bevins wrote: Build your basic setup in stepconfig and dont look back.

Get into the hal file and tweak from there.

Just a thought


I have, thats when i found my home switches not functioning. I clicked home all and my Z hit the switch and continued in the same direction.

I dont like to, but i am running it with the home switches unused right now and just manually calling home in a near home position. and zeroing my DROs in that position in case for any reason i loose position and need to continue a program.]

21 Apr 2017 11:05 #91768 by tommylight
Check the switch wiring, one of the pins must be connected to ground when using only parallel port, but most BOS's require the common to be connected to +5V. Some have jumpers to change that as needed.
21 Apr 2017 14:32 #91788 by MAG45
I tested that, found 5v at the BoB and 5v through each switch broken when toggle the switches.
21 Apr 2017 20:52 #91806 by tommylight
That will not work directly on parallel port, but it might be OK for the BOB.
Can you disconnect the common wire and wire it to ground and report back what happens, please?
Thank you.
21 Apr 2017 21:07 #91808 by MAG45
Not sure what you mean. Disconnect the common wire, the one going to the ground pin of the bob? What am i looking for results in, Ptest?

They are wired as shown here cnc4pc.com/Tech_Docs/C10R10_WG.pdf
21 Apr 2017 21:30 #91809 by tommylight
Nice, that is very useful.
So when using Ptest, your e-stop works but limit switches do not, right?
2 things:
1. on the BOB one the right side there is a jumper for setting inputs other than 2-9 as pull up or pull down, does it have a jumper in place, if it does move it to the other place and test again.
2. if that does not work, get a short piece of wire, disconnect the switches, start ptest and short the input 12, 13, 14 to the GND on the BOB.
If all this fails, disconnect the DB25 cable from BOB, take a small screw driver and find pins 10,11,12,13,15 on the port, they are vritten inside near the pins, while the ptest is on, short each of those pins to the metal shielding.
21 Apr 2017 21:56 #91812 by MAG45
Yes the jumper is in 'pull down' which is what is said to use in the full BoB manual. I have effectively tested 12, 13, and 14 by trying them for my switches. I will try it direct also, then try the db25 cable test.
Time to create page: 0.088 seconds
Powered by Kunena Forum