× Forum Header

Step Outputs Inactive

More
24 Aug 2017 14:34 #97964 by kylestrong87
kylestrong87 created the topic: Step Outputs Inactive
Hi,

I am new to LinuxCNC and the forums. I have done a search but haven't found a similar problem or solution to my issue. I have been trouble shooting the outputs for a couple days now with now luck. At first I was getting zero output or input. After a fewer tests I ended up changing my LPT protocol in the BIOS from "PS/2" to "EPP". At this point I instantly got my limit switches and "DIR" outputs running correctly. But I am still having no "STEP" outputs coming from LinuxCNC. I suspect it is something I am missing in the set up of StepConf or LinuxCNC itself. I do not believe it is a driver issue because when i use the LPT test app that comes with LinuxCNC I can produce 5VDC on the "STEP" pins on the breakout board. I am using pins 2,4,6,8 for "STEP" and pins 3,5,7,9 for "DIR".

System Info:
LinuxCNC 2.7 (+plus linux from livecd)
CNC4PC C10 Breakout Board
4 Gecko G201
4 Stepper (3 Axis)
More
24 Aug 2017 19:55 - 24 Aug 2017 19:56 #97973 by Todd Zuercher
Todd Zuercher replied the topic: Step Outputs Inactive
Could you share your ini and hal files for your config? So we can check them for obvious errors.

PS: (This is totally unrelated to your step generation problem.)
I suspect that you are setting up a slaved gantry type machine (hence the 4 steppers for a 3 axis machine). If that is the case. It might be wise for you to run the Development version of Linuxcnc. (At least until version 2.8 is released.) It contains support for assigning more than one motor to an axis, and homing and squaring them in the homing routine.
But you need to be aware that 2.8-Pre is currently the "develoment branch" and updates need to be made with cation, as changes in the code can introduce bugs or break configs. That said, many people use it safely for running real machinery.
Last Edit: 24 Aug 2017 19:56 by Todd Zuercher.
More
24 Aug 2017 22:38 #97974 by kylestrong87
kylestrong87 replied the topic: Step Outputs Inactive
Thank you for the advice. I will definitely look into 2.8. Attached you will find all .hal and .ini files that were in my config folder. Thank you for the help. I knew I was going to run into things like this, just not sure how to address them since my understanding of how LinuxCNC works is minimal so far.
More
30 Aug 2017 13:46 #98207 by andypugh
andypugh replied the topic: Step Outputs Inactive
You have set the step length to 500nS (or, at least, Stepgen has done that for you).
How are you determining that the step pulses are not working? You won't be able to see a 500nS pulse with a multimeter.
More
04 Sep 2017 13:09 #98467 by kylestrong87
kylestrong87 replied the topic: Step Outputs Inactive
So any suggestions on how to log the data being transmitted if any at all on the Step Pins? I need to find out where I'm losing the data. It's either My LinuxCNC Setup (Which I suspect), the C10, or the Gecko drives.

I have not had any luck finding a Parallel port logger for linux.

I have used the parport tester that came with linuxcnc and those pins do transmit 5vdc which I can read on the c10 board. Also when I test those pins my motors do try to step manually. This is why I suspect LinuxCNC because if it was sending the signal or sending it properly then I would at least hear the motors try to move. Just to confirm my direction pins are working properly I can see them changing and holding voltage when the program changing direction.
More
05 Sep 2017 09:55 #98522 by andypugh
andypugh replied the topic: Step Outputs Inactive
Your step length seems rather short (500nS).
Try 5000nS and see if things work better.
You might also want to invert the step pins.

Both of these are simple edits to the HAL if you prefer not to run stepconf again.
the "reset time" sets the step length in nS and the pins can be inverted with a line like you already have for pin 7
setp parport.0.pin-07-out-invert 1
More
05 Oct 2017 15:49 - 05 Oct 2017 15:50 #99967 by kylestrong87
kylestrong87 replied the topic: Step Outputs Inactive
Hi guys thanks for the help.

Here was my solution:
1. I had to change the LPT protocol. I had it set to EPP (recently posted) and the DIR output worked but not the STEP. I changed this to ECP in the BIOS.

2. I changed my STEP to inverted. I believe this was suggested because the Gecko G201 read the back end of the signal not the front end? Thank you ANDYPUGH for the help on that.

Things I Learned that Might help if you all haven't figured it out yet:
1. If you have a gantry Stepconfig will not move two motors on once axis at the same time. For instance I could not figure out why phase B was firing on my X #2 but phase A was not. Thought there was a problem with my driver so while metering the signal I accidently shorted phase A to B and burnt out the driver had to order a new one. Stupid me if I just ran the LinuxCNC not stepconfig both motors would have worked. Realized this when testing the new driver...

2. Stepconfig seems to not accurately use your gear ratio, revs per inch, and all that stuff until you open LinuxCNC. When jogging stepconfig to .5" its good, when you open LinuxCNC its the real measurement and is a third of .5".

3. Stepconfig doing the math for you is more confusing then doing it yourself.

4. You can not use EPP protocol, it has to be ECP.

5. You can use a cheap meter to see the STEP voltage on that pin.

6. Have not learned how to get my Limit Switches set up properly. They are wired NO and every time I try to run the machine linuxcnc gives me a limit switch error. When I change to inverted on that pin I have the same issue.
Last Edit: 05 Oct 2017 15:50 by kylestrong87.
Time to create page: 0.071 seconds
Powered by Kunena Forum