× Forum Header

Can't get stepper motors to move at all

More
27 Jan 2018 20:58 #105078 by mpayne
First, thanks for taking the time to read my post. I’ve really tried to solve this on my own but I’m getting nowhere

I’m moving my CNC setup from a (very old) PC running Windows XP, Mach3 and a MX3660 to a new PC with a fresh install of LinuxCNC 2.7. I’m using the same MX3660 and the new PC has a PCIe parallel port card. The card is a SD-PEX10005 which is a netMOS 9900 chip. The system works on my XP machine

My problem is I cannot get any of the stepper motors to move. My parallel port is working because my E-STOP works in linuxCNC. I can press the button and LinuxCNC goes into stop mode. When I release the button it exits stop mode.
When I jog in LinuxCNC the display shows the spindle moving the correct direction, but my CNC machine is motionless.
I’ve tried running the step config many times trying different things, using my Mach3 XML file and using new config. I tried adding my user to the LP group in case it is a permissions problem. Nothing is working. I’ve read through the posts here and tried just about anything I can find. I’m out of ideas to try. Can anyone suggest something I can do to figure out the problem?

Thanks for your help,
Mike
More
27 Jan 2018 21:37 #105079 by Clive s
It would help if you uploaded your |Hal and Ini files from the config folder. It might be that the drives are not enabled.
More
27 Jan 2018 21:51 #105081 by mpayne
Thanks for the reply. Here are the INI and HAL files. Thanks!

File Attachment:

File Name: MX3660.hal
File Size:3 KB

File Attachment:

File Name: MX3660.ini
File Size:2 KB
Attachments:
More
27 Jan 2018 22:04 - 27 Jan 2018 22:12 #105082 by PCW
You might try doubling the step lengths to 3000 ns (3 usec) = the "reset time"
1500 ns is too fast for the MX3660

The MX3660 specs say 2500 ns minimum step length
( and minimum means on the edge of not working... )

Edit:
Also the MX3660 manual says this:

"If step & direction signal voltage is lower than 5 VDC, you may need to increase step
width and direction setup time (> 5 uS) to move your motors, or avoid loss of step."

Pretty sure the NetMOS 9900 is s 3.3V chip so you may need a reset time of 5000 ns
Last edit: 27 Jan 2018 22:12 by PCW.
More
27 Jan 2018 22:49 #105086 by mpayne
I tried increasing the times and still no movement. Here is the new HAL file that was generated



File Attachment:

File Name: MX3660_201...27-2.hal
File Size:3 KB
Attachments:
More
27 Jan 2018 22:55 #105087 by PCW
You might try disabling the chargepump logic on the MX3660 just in case theres an issue with it
More
27 Jan 2018 23:16 #105088 by mpayne
That did it! Thank you so much for your time.
More
27 Jan 2018 23:18 #105089 by Clive s
Glad you got it working.
Time to create page: 0.074 seconds
Powered by Kunena Forum