× Forum Header

Laucher does not run stepper motors_Axis runs fine.

More
15 Feb 2019 18:01 #126574 by JackB1
With all this done in Stepconf. And with the mill responding during the “Test this Axis” for each axis. When I run the Launcher, start the machine and run the LinuxCNC default G-Code. The Axis screen shows it following the G-Code as it should. But, now NONE of the steppers on the mill are moving at all.

Thank you,
Jack “I’m stuck on this one” Burnsworth
Below is everything I have. Also attached as Word document.

LinuxCNC Ver. 2.7.14

Stepconf Wizard settings as follows.

Base Information
Machine Name: Grand-Pa_Prb_Estp_V1.3
Configuration Dir: ~/linuxcnc/configs/Grand-Pa_Prb_Estp_V1.3
Axis Config: XYZ
Machine Units: Inch

Driver Type = Other
Step Time = 6000 ns
Step Space = 6000 ns
Direct. Hold = 5000 ns
Direct. Setup = 5000 ns
One Parport: *
Base per Max Jit: 15000 ns
Min Base Period: 21000 ns
Max step rate: 23809 Hz

Parallel Port 1
Outputs Inv. Inputs Inv.
Pin 1 = ESTOP Out Pin 10 = Unused
Pin 2 = x step Pin 11 = Unused
Pin 3 = x dir Pin 12 = Unused
Pin 4 = y step Pin 13 = ESTOP in
Pin 5 = y dir Pin 15 = Probe in
Pin 6 = z step
Pin 7 = z dir
Pin 8 = Unused Parport Base Address = 0
Pin 9 = Unused Output pinout presets = Sherline
Pin 14 = Spindle CW X
Pin 16 = Unused
Pin 17 = Unused

Options

Include Halui = checked include custom PyVCP = checked
Onscreen prompt for manual tool change = checked

Axis X, Y & Z
Motor steps per revolution: 200
Driver Microstepping: 16 (X, Y & Z set to same)
Pulley teeth: 1: 1 (X, Y & Z set to same) (Direct Drive)
Leadscrew Pitch: 20 rev/in
Maximum Velocity: 1.0 in / s
Maximum Acceleration: 20.0 in / s²

Home Location: 0
Table Travel: 0 to 8 = X, 0 to 5.0 = Y, Z = -4.0 to 2.0
Home switch location: 0 for all Axis (Not used yet)
Home search velocity: 0.05 for all
Home latch direction: Same used for all axis

Time to accelerate to max speed: 0.0500 s
Distance to accelerate to max speed: 0.0250 in
Pulse rate at max speed: 64000 hz
Axis scale: 64000.0 Steps / in
200 x 16 x (1.0 ÷1.0) x 20.000 =

Test this axis
Velocity: .07 in /s
Acceleration: 20.0 in /s²
Left and Right jog works Excellent.
Test area also works as it should.

I’m using the Chinese Blue 5-axis controller from Sain Smart. And the MD430-V1.4 stepper driver boards with the following settings. Which work awesome when running the “Test this Axis”.

SW 1 = 1, SW 2 = 1, SW 3 = 0 for current of 2.0(A)
S1 = 0, S2 = 1 Decay mode of 50⁒
S3 = 0, S4 = 1 Excitation mode of 16 microsteps
S5 = 1, S6 = 0 Torque settings of 75⁒
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Feb 2019 16:57 #126611 by pl7i92
DOPPEL POSTING
Join the irc for live Help
Estop not correct

Please Log in or Create an account to join the conversation.

More
16 Feb 2019 17:52 #126618 by JackB1
First where do I join the IRC and what do you mean ESTOP incorrect? I connected it between pin 13 and ground.

Please Log in or Create an account to join the conversation.

More
16 Feb 2019 18:19 #126620 by JackB1
THANK YOU for the guidance. Disconnected the ESTOP button and voila' IT WORKS. Thank you again. Still don't have a clue how to get on the IRC help thing though.
Sincerely'
JackB1

Please Log in or Create an account to join the conversation.

Time to create page: 0.075 seconds
Powered by Kunena Forum