× Forum Header

LTP DPTR + Zero Tool

04 Dec 2019 15:28 #152001 by Doc
LTP DPTR + Zero Tool was created by Doc
Good day. There is an optocoupling board LTP DPTR 1.03, sensors

The zero and the instrument height sensor, the zero and instrument height sensor are connected to one LPT pin (Z-limit / Z-probe). All sensors are connected, the machine parks to zero, everything works. However, if you also connect a zero sensor to the same connector, (an ordinary tablet), then it does not respond to
G38.2. But it reacts when parking to zero (when parking, touch the tool sensor), i.e. connected correctly. As I understand it, I need to configure the pin in the config correctly, now it is configured as home. Having tried all the options home + limits, nothing worked, just when I try to park, I get an error. ask
Sorry for the confused description. Perhaps there is experience in this problem, or at least it can prompt that it is possible to diagnose in order to understand the reason, very few people use this board ...
Thanks in advance for any help ...

Please Log in or Create an account to join the conversation.

05 Dec 2019 14:09 #152065 by andypugh
Replied by andypugh on topic LTP DPTR + Zero Tool
This does not sound like a problem specific to the board.
This is more likely to be a problem in your HAL config. For example wiring the limit switch and the probe to the same input is a little unusual.
(but might make sense, with some HAL logic to redirect the input when the machine motion mode is "probing"

Please Log in or Create an account to join the conversation.

Time to create page: 0.474 seconds
Powered by Kunena Forum