× Forum Header

plotter: trying to control bob relay (bob 5axis v5 bad docs)

More
14 Nov 2020 10:48 - 14 Nov 2020 10:57 #189317 by lhenry
Hi!
Amazed by how fast I was able to run my axis being a complete cnc newby ..

I want to build a plotter but got stuck on using the realy of my chinese bob board (5 axis, 1 relay).

I asseigned digiatl output 0 to pin 16 but is always on , and most important M62...M65 ar not active commands available to the machine..

I also read about using the z axis to control the on/off of the tool (a laser on/off or a pen up/down) .. wich solution shoud I go with ?

Pin 16 is off when I boot the PC .. When I run a machine with pin16 hooked to digital Output the replay goes on (regardelss of the invert checkbox in stepconf). By this moment is remains ON even if I close linucnc application


thnak you !
Last edit: 14 Nov 2020 10:57 by lhenry.

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 12:09 #189322 by Aciera
Can you post your .ini and .hal files?

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 15:40 #189338 by lhenry
Hi There,
here are the files

Thank you !
Attachments:

Please Log in or Create an account to join the conversation.

More
More
15 Nov 2020 17:19 #189465 by lhenry
Non being able to turn on the relay using any of mist, flood, digital output etc... I belived that BoB documentation were wrong, so tested other than the pin 16 and was pin 14.
Now I can do M7/M9 to successfuly turn on/off my relay.

Now I will do some little hacking to the gcode produced by inkscape and replace the Z codes with M7/M9.

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum