× Forum Header

I do not find "base period" or "motor steps per rev" in my .ini File

More
20 Jun 2021 09:31 #212471 by Roman Simon
Hello,

I just started with the Stepper Configuration Wizard and looked after this in the .ini File
For example, I typed in "base period" 35000 and the generated ini file contains only
"BASE_PERIOD = 100000". Or I cant find "motor steps per rev" (200) or "microstepping" (2) here,
or in other generated files.

My systems works fine (so far), but I would like to know how these things work together.

Thanks & Best Regards
Roman

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 11:27 - 20 Jun 2021 11:33 #212476 by BeagleBrainz
It's the SCALE parameter you're looking for.
That's how many steps per millimeter or inch.

Say for instance you have a 5mm pitch leads screw, with 200 steps per rev & 8 micro steps.

scale = STEPS_PER_REV * MICRO_STEPS / LEADSCREW_PICT
= 200*8/5
= 1600/5
= 320

Stepconf asks you for base period max jitter, then calculates the actual base period based on the figure you put in for the jitter. If you open up stepconf and reread the Base Information page you'll see what I mean.
Last edit: 20 Jun 2021 11:33 by BeagleBrainz.
The following user(s) said Thank You: Roman Simon

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 13:59 #212485 by Roman Simon
Thank you, know I understand scale. But BASE_PERIOD do not seems to work proper here.

When I enter "Base Period Max Jitter" 35.000, "Min Base Period" is calculated in the info down there as 50.000. But *.ini is written with 100.000

When I enter 50.000, "Min Base Period" is calculated 65.000 but *.ini is still 100.000.

I use this the RTAI Version
linuxcnc.org/docs/2.8/html/getting-start...#cha:Installing-RTAI

No problem to correct this manually but I would like to be sure, that 50.000 is the right value

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 16:38 #212497 by tommylight

No problem to correct this manually but I would like to be sure, that 50.000 is the right value

It might not be, cheap stepper drives use cheap optocouplers, so sending fast pulses to them results in no movement from motors, causing aggravation with users.
Test with default 100000, after you are sure the motors are running properly and the scales are ok, you can edit the ini file and change that.

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 17:09 #212501 by BeagleBrainz
Going by the docs 35000ns is about 16% over what is recommended for software stepping.
I’d be looking to reduce that via some bios tweaks to reduce that.
Have you looked in your bios and turned off any power saving and hyperthreading ? On a multi core CPU it might be an idea to use the isolcpus kernel option.
Or if it’s an older machine Wheezy might be worth a try.

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 20:06 #212511 by Roman Simon
hi, I tested my mini mill with 50.000 Base Period and seems to run very fine



I think the 100.000 is just a bug in the RTAI version, this value does not change, when changing "Base Period Max Jitter"... and it should

@BeagleBrainz this is the best I can achieve with my pc, its a longer story
forum.linuxcnc.org/38-general-linuxcnc-q...h-57000-good-enought
Also, I have the linuxcnc settings from the sherline factory computers
www.sherline.com/product/linuxcnc-comput...-without-driver-box/
and they use also 50.000. This should works fine with the sherline driver box.

Please Log in or Create an account to join the conversation.

More
20 Jun 2021 21:28 #212517 by tommylight
Do you get latency warnings on the lower right corner ?
If not, all is good, you can even try a bit lower base period although probably no need for it.

Please Log in or Create an account to join the conversation.

More
21 Jun 2021 02:02 - 21 Jun 2021 02:04 #212530 by BeagleBrainz
I don’t think there is any code change between the version of stepconf in the uspace or rtai versions.
I plugged in the same values on a uspace Linuxcnc package and got the same results.

As there is no input value for the option coupler in stepconf & latency won’t affect rise and fall times of the parallel, it’s the parallel port hardware that would affect this. You would have to have god awful optocouplers to get to a point where they come into play to affect stepping. Like really really bad, due to major manufacturing defects. Or instead of a photo transistor they use a gnome encapsulated in the package who turns on a switch as the LED goes on & off.
Add to that the stepper timings recommended by various posts and docs for Linuxcnc are pretty conservative.
Last edit: 21 Jun 2021 02:04 by BeagleBrainz.

Please Log in or Create an account to join the conversation.

More
21 Jun 2021 04:21 - 21 Jun 2021 04:22 #212535 by Roman Simon
I do not get a latency warning :)

Regarding stepconf, I hardly know anything here ...
but this value, red



is not written to the ini file. its always 100.000
Attachments:
Last edit: 21 Jun 2021 04:22 by Roman Simon.

Please Log in or Create an account to join the conversation.

More
21 Jun 2021 07:40 - 21 Jun 2021 08:03 #212541 by BeagleBrainz
Last edit: 21 Jun 2021 08:03 by BeagleBrainz.

Please Log in or Create an account to join the conversation.

Time to create page: 0.136 seconds
Powered by Kunena Forum