× Forum Header

I think I found a bug

05 May 2023 06:07 #270698 by dog
I think I found a bug was created by dog
I think I found a bug in the StepConf Wizard.  I'm a very new linuxcnc user so maybe I did something wrong but I don't think so.  I'm working with a fresh install of Debian 12 and linuxcnc, talking to my stepper driver with a PCIe parallel card through a CNC4PC breakout board.

Here's what I did...
I ran the StepConf Wizard from the apps menu and when I got to the part of setting up each axis there's an option for testing the axis.  I ran the test and my motor makes a nasty noise but doesn't move.  I then completed the wizard which creates a desktop icon for launching linuxcnc.  I used that to launch linuxcnc and from the main screen turned off the e-stop, enabled the motors, selected the appropriate axis (I'm only working with one motor right now testing the setup), and used the jog feature to test the motor and it runs very well.  I changed the speeds, length of the jog including continuous mode, etc and the motor is running nicely so it's not a problem with the motor driver or the timing values I entered into the wizard.  I then went and retested the StepConf wizard (opening the file previously created) and it still doesn't work.  So it seems to me that there must be something wrong with how that test function inside the StepConf Wizard is creating the Step/Dir signals.  I thought someone might like to know.


Please Log in or Create an account to join the conversation.

05 May 2023 17:41 #270741 by dog
Replied by dog on topic I think I found a bug
OK, I was playing with the machine this morning and figured out what the problem is/was. I had confused inches per minute vs inches per second. So, the feed rate was set 60X too high, thus the frequency of pulses going to the motor was too high and it just vibrated (sounds horrid). Anyway, after reducing the speed a lot everything works great.

Any moderators prefer if I delete this thread or let it live in the hopes it helps someone in the future?

Please Log in or Create an account to join the conversation.

Time to create page: 0.104 seconds
Powered by Kunena Forum