× Forum Header

Stutter in Stepper Config moves

More
13 Apr 2009 20:52 #75 by chiefgeek
I'm building a gantry style mill/router and have found a problem with the pulsetrain while testing an axis.

After setting the step and direction output parallel port pins and in the x-axis setup screen I tell the axis to jog or cycle back and forth. When doing this, there is a stutter in the movement when ever I move the mouse, type a key, or when anything on the screen changes, including the blinking cursor.

The pulse timing is set to the L297 setting (it's an L297 based stepper drive) and the minimum scan time of the compter is 25000 ns. Changing this to 50000 ns, doesn't help.

When running the latency test, the max jitter is around 24000ns no matter what I do, including much typing, mousing, and asking for all kinds of openGL graphics while playing a video.

I don't think it is electrical noise because how would the blinking cursor make the difference in the noise from the video signal. I'm guessing it is some kind of interrupt of the PC that the latency test can't see.

Can anyone point out what I'm missing?

Thanks in advance. Chief Geek

Please Log in or Create an account to join the conversation.

More
14 Apr 2009 08:12 #85 by alex_joni
chiefgeek wrote:

Can anyone point out what I'm missing?

Thanks in advance. Chief Geek


hi there,

not much I can think of that you're missing.
You could maybe try the RTAI latency test, maybe our test is missing something (hard to believe though).

Go to /usr/realtime-*/testsuite/kern/latency/
and "sudo ./run" (or something along those lines, I'm quoting from memory..)

If that looks ok, maybe you can use halscope to try to capture a pulse train, and see if there is anything visible.

Regards,
Alex

Please Log in or Create an account to join the conversation.

More
26 Apr 2009 14:41 #165 by dfarrell
I'm not sure how much it exercises the software but you might try to use the
stepper sim_inch configuration. You could then manually jog and listen to
the PC speaker to try to hear discontinuous tone. What step rates are you
using?

Please Log in or Create an account to join the conversation.

Time to create page: 0.082 seconds
Powered by Kunena Forum