Preemptive RT on Jessie or Stretch?

More
07 Jul 2018 13:38 #113667 by tommylight
Consider this a message !
I do not like writing to e-mails, they are private and should remain so. I have had plenty of forum users sending me e-mails with the same questions as here on the forum. And therein lies the problem as if i reply to them they get my e-mail address so the spam runs rampant ! Already had one private email made useless after several years of use by some users on some other forums.
Usually i give my mobile phone number way easier than the e-mail.
Unfortunately this forum does not have private messages.
Make it available for a limited time on google drive or similar and remove it after the time expires.
Thank you.
Tom

Please Log in or Create an account to join the conversation.

More
07 Jul 2018 14:33 #113670 by AnnoyingMutt
Sharing has been removed, files are longer available.

Please Log in or Create an account to join the conversation.

More
07 Jul 2018 22:41 - 07 Jul 2018 22:42 #113732 by andypugh

bymccoy wrote: So, since last asking in May, has anybody else gotten Jessie/Stretch working?


Yes, by the simple expedient of using the LinuxCNC Stretch live-DVD.

www.linuxcnc.org/testing-stretch-rtpreempt/
Last edit: 07 Jul 2018 22:42 by andypugh.

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 15:18 #116713 by twoflowers
I tried the linked isos. While they work, it's not an enlightment. The latency figures of the 4.9 RTPREMPT kernel are plain horrible compared to the RTAI kernel (about 5 to 10 times higher).

I alsotried upgrading from wheeze->jessie->ascii/stretch. This works, but the RTPREEMT kernel ... Anyhow, now I run devuan ascii on the wheezy kernel. While axis from wheezy works on jessie, it fails on ascii/stretch. gmoccapy works, but I need axis :/

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 15:36 #116714 by PCW
What hardware do you have? recent Preempt-RT kernels can have very good latency figures on the right hardware:

freeby.mesanet.com/8300-4.18.png

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 15:50 #116717 by twoflowers
I ran this on T60/T61 C2D, one with ATI and the other with Intel GPU. Latency on RTAI is ~ 5.000ns, on RTPREEMT ~ 70.000ns. I get the same figures on my old Desktop (gigabyte+xenon). What is more troubling on the Intel boards: I cannot turn off SMI any more. This gives additional 450.000ns peaks every now and then. I would not see this as a problem if that very same hardware would not have worked before.

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 16:23 - 28 Aug 2018 16:27 #116721 by PCW
Heres a recent Preempt-RT running on a C2D desktop
(10 glxgears +running youtube videos)



Not sure what the SMI issue is...
SMI seems to not be used at all on modern desktops (I've never needed to use a SMI workaround on intel CPUs)
Attachments:
Last edit: 28 Aug 2018 16:27 by PCW.

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 22:28 - 28 Aug 2018 22:29 #116745 by twoflowers
Ok, these are my figures: Testsubject is my T61 with intel gpu. I booted the official 2.7 linuxcnc dvd, this is the latency out of the box:



This is the same computer, this time I booted the strech dvd from your link (amd64) - no glxgears this time, running those does not change the numbers:

Attachments:
Last edit: 28 Aug 2018 22:29 by twoflowers.

Please Log in or Create an account to join the conversation.

More
28 Aug 2018 23:42 - 28 Aug 2018 23:44 #116750 by PCW
Well its not so good on RTAI either (512 usec)

That does look pretty terrible though possibly your CPU cannot run a 40 KHz thread with Preempt-RT so everything is broken

(trying with servo thread only would show if this were the case)
Last edit: 28 Aug 2018 23:44 by PCW. Reason: Minimum time doesnt mean that due to the way its calculated

Please Log in or Create an account to join the conversation.

More
29 Aug 2018 06:52 - 29 Aug 2018 07:04 #116763 by twoflowers
Oh, these spikes are from SMI and go away when I disable SMI with smictrl. As it's not included in the DVD, I didn't bother.

This is from a X200

So, what hardware is needed for Rreempt-RT? Are all CPUs alder than 10 years out of the game?
Attachments:
Last edit: 29 Aug 2018 07:04 by twoflowers.

Please Log in or Create an account to join the conversation.

Time to create page: 0.156 seconds
Powered by Kunena Forum