latency issues with ga-j1900n

More
06 Nov 2018 22:04 #120122 by Todd Zuercher
I certainly wouldn't isolate 3 of 4 cores on a j1900. I might try 1 or 2 of them just for comparison. And it often pays to try isolating different cores or combinations of them. (The i5 i'm playing with right now gives best results with isolcpues=3.) But depending on the setup you have it may not even be worth the effort.

Please Log in or Create an account to join the conversation.

More
06 Nov 2018 23:09 #120126 by jamby
Replied by jamby on topic latency issues with ga-j1900n
Todd and rodw

I let the last one run for a lot longer and also ran a latency-test -1ms. Results below:





During both of these I was ssh'd into the box and using apt-get, 7 glxgears, and ncftp to transfer files for my machine to linuxcnc/configs/
so the numbers are not as good.

thanks
Jim
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Nov 2018 23:18 #120127 by PCW
Replied by PCW on topic latency issues with ga-j1900n
oops 2 ms latency on a 1 ms thread is nogo

Is it possible you have some power management option still enabled or a bad harddrive?

I dont think I've seen that bad on anything other than laptops

Please Log in or Create an account to join the conversation.

More
07 Nov 2018 15:50 - 07 Nov 2018 15:54 #120176 by jamby
Replied by jamby on topic latency issues with ga-j1900n
PCW

Here's two screenshots one after 3hrs the second after 15hrs





these were done as shown with no other actions, such as the ssh connection and apt-get execution during them.

Thanks
Jim
Attachments:
Last edit: 07 Nov 2018 15:54 by jamby. Reason: include the pictures

Please Log in or Create an account to join the conversation.

More
07 Nov 2018 17:40 #120188 by PCW
Replied by PCW on topic latency issues with ga-j1900n
Still nearly 1000000 ns latency
I still suspect you have a power management option (say C states >C1 enabled) enabled in the BIOS or bad hardware (bad drives can do this)

Please Log in or Create an account to join the conversation.

More
08 Nov 2018 12:04 #120250 by andypugh
Is there any chance this is SMI?

Please Log in or Create an account to join the conversation.

More
08 Nov 2018 14:48 - 08 Nov 2018 14:50 #120268 by jamby
Replied by jamby on topic latency issues with ga-j1900n
PCW andypugh

The key was PCW's C states C1, that was the first time I found out that value was power related.

Now here's the latest histograph



Looks good enough for me. So its Wheezy for me.

Thanks
Jim
Attachments:
Last edit: 08 Nov 2018 14:50 by jamby. Reason: spelling correction

Please Log in or Create an account to join the conversation.

Time to create page: 0.181 seconds
Powered by Kunena Forum