G code is not working...

More
16 Nov 2010 16:05 - 16 Nov 2010 16:08 #5343 by BigJohnT
I didn't see anything in dmesg. You have to check the last position as well as the arc to see if your in the correct starting position. With Arc Buddy you can define the center and the start and end angles and it gives you the two lines needed so it helps me make sure my post is putting out the proper start position as well as the correct arc move.

Screen Capture works.



John
Attachments:
Last edit: 16 Nov 2010 16:08 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:08 #5344 by axel88
Replied by axel88 on topic Re:G code is not working...
The G91.1 comand doesn't work.

I made some Screenshots from the PostBuilder, perhaps you'll find some wrong configured options.
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:09 - 16 Nov 2010 16:10 #5345 by axel88
Attachments:
Last edit: 16 Nov 2010 16:10 by axel88.

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:10 #5346 by axel88
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:11 #5347 by axel88
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:27 - 16 Nov 2010 16:27 #5348 by BigJohnT
I don't see anything that sticks out. Can you generate a simple line and arc and post that?

X Center 1.000
Y Center 1.000
Diameter of Arc 1.000
Start Angle 90
End Angle 270
Arc Direction CW

See if it matches this:



John
Attachments:
Last edit: 16 Nov 2010 16:27 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:30 #5349 by andypugh
BigJohnT wrote:

I didn't see anything in dmesg. You have to check the last position as well as the arc to see if your in the correct starting position


You know what is odd? The arc works if you take the centre relative to the _end_ position.

Is there an option to switch the postprocessor to absolute arc centres?

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 16:57 - 16 Nov 2010 17:00 #5350 by axel88
Replied by axel88 on topic Re:G code is not working...
I think i found the option to switch the postprocessor to absolute arc centres:



But I'm not sure in wich word i have to change the format.

In K_cycle or in K itself or anywhere else?
Attachments:
Last edit: 16 Nov 2010 17:00 by axel88. Reason: picture wasn't uploaded

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 17:01 #5351 by axel88
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Nov 2010 17:07 #5352 by andypugh
That looks like the wrong screen, but the I, J , K a little further up the list might be the right place.

Otherwise it will be in the G2, G3 section.

Please Log in or Create an account to join the conversation.

Time to create page: 0.207 seconds
Powered by Kunena Forum