Question about rotary toolpath display.

More
15 May 2015 02:44 #58704 by color
Hi to all,
I have a 4 axis CNC milling machine and I can not configure Linuxcnc to display rotary toolpath. When joging A axis the visualisation of the tool is corrrect but if I load a G code with some rotary toolpath, it isn't displayed correct, I only see a flat blue lines and the tool moves in flat surface instead rotary traectory. If I load a 3axys G code I see the entire model with white lines and the tool follow exact path but in rotary don't. Is this bug in AXIS or my configuration is wrong?

Please Log in or Create an account to join the conversation.

More
More
15 May 2015 17:14 #58717 by color
Thank you for the answer, ArcEye
I have set my INI file to GEOMETRY = XYZA. I see the tool cone rotate around X axis when jog it, but don't see the toolpath like a 3D object. Do you mean that this is impossible in Linuxcnc and the rotary toolpath is displayed always wrapped?

Please Log in or Create an account to join the conversation.

More
15 May 2015 17:17 #58718 by ArcEye
There is a limit to what you can get a 2D display to show

Did you try this one?
www.linuxcnc.org/index.php/english/forum...s-on-cylinders#40497

regards

Please Log in or Create an account to join the conversation.

More
15 May 2015 17:29 #58720 by color
Not yet, I will try this. I must change INI to 9axix GEOMETRY if I understand correct?

Please Log in or Create an account to join the conversation.

More
15 May 2015 17:31 #58721 by andypugh

color wrote: Not yet, I will try this. I must change INI to 9axix GEOMETRY if I understand correct?


No, you just need to use GEOMETRY=AXYZ rather than XYZA

Please Log in or Create an account to join the conversation.

More
15 May 2015 18:33 - 16 May 2015 12:02 #58728 by color
Ah, OK, Thanks.
I will try this .

Update - the AXYZ configuration works, but now have the following bug: When open G code and the machine is set in zero machine coordinate, everything looks fine. When do touchoff and set G54 or G55 or other user specified position, the visualisation of the toolpath start deforming. Like a sample, the ring with 30mm diameter looks like a ring with 120mm diameter. I tried AXYZ, XAYZ and XYAZ, always the same result.
Last edit: 16 May 2015 12:02 by color.

Please Log in or Create an account to join the conversation.

More
25 Nov 2019 11:32 #151210 by neller
Any solutions this?
Hello all, I have the same issue "the visualisation of the toolpath start deforming".It happens when we works in non-zero absolute coordinates, but I think the physical aspect works fine: this issue appears only on visualisation window.

Please Log in or Create an account to join the conversation.

More
28 Nov 2019 19:50 #151450 by andypugh
Sorry, no, that is just the way it is. The graphical preview has no way to know where the centre of rotation is relative to your work coordinate system. (Literally no way, this is not an easy thing to fix)

Please Log in or Create an account to join the conversation.

Time to create page: 0.104 seconds
Powered by Kunena Forum