Missing the right side PYVCP panel

More
30 Jan 2019 14:30 #125291 by Buddy002
My panel does not launch and as I read the documentation I have everything I need. I have panel.xml under DISPLAY PYVCP = panel.xml. I have POSTGU.halI = custom_postgui.hal under HALFILE. The file gustom_postgui.hal calls Panel_options.hal and panel.xml. Panel_options.hal and panel.xml have both worked in the past.

I had moved this mill and during shipment the monitor and hard drive where destroyed. With the new hard drive I installed the latest stable image.

Please Log in or Create an account to join the conversation.

More
31 Jan 2019 14:50 #125389 by pl7i92
It Shoudt be There if your monitor is at 1024 or above

using Debian weezy or stretch 2.7.14

AXIS as GUI

Please Log in or Create an account to join the conversation.

More
31 Jan 2019 16:56 #125410 by Buddy002
Thanks for your reply. I changed the monitor resolution to 800 x 600 but the problem still exists. On my previous build I had similar problem. I stumbled on to a solution by having one file call another file and changing file names. This solution made no sense. So this time I went to the latest documentation and followed that. Are you familiar with the file name rules.

Please Log in or Create an account to join the conversation.

More
01 Feb 2019 00:02 #125439 by BigJohnT
Zip and attach your config files so we can see what you have.

JT

Please Log in or Create an account to join the conversation.

More
02 Feb 2019 18:12 #125557 by Buddy002
Attached is the files I have tried, included is the ini file which calls PYVCP = panel.xml in [DISPLAY] and POSTGUI_HAL = pyvcp_panel.hal which is all that is required as I understand it. Panel.xml has the widgets and label spacing and has worked in the past. PYVCP has the pin assignments and has also worked in the past.
Attachments:

Please Log in or Create an account to join the conversation.

More
13 Feb 2019 14:22 #126344 by andypugh
Catching up after a holiday. Is this problem still there?

Please Log in or Create an account to join the conversation.

More
13 Feb 2019 16:15 #126351 by Buddy002
The problem still exists. I am currently setting up another computer and instillation.

Please Log in or Create an account to join the conversation.

More
14 Feb 2019 03:40 #126432 by phillc54
There are a few of typos in pyvcp-panel.xml
hal pin for bar was pyvcp.spindle-speed instead of spindle-speed
missing end tag for second vbox
almost all the code was inside a single tag
corrected file is attached

Cheers, Phill
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Feb 2019 20:08 #126488 by Buddy002
Thanks for you for your help but the problem still exists. However now I know the xml and hal files are functional. I am thinking that the machine is launching from the incorrect file

Please Log in or Create an account to join the conversation.

More
14 Feb 2019 22:01 #126497 by phillc54
If you are running linuxcnc from the command line you should get an error message.

Cheers, Phill.

Please Log in or Create an account to join the conversation.

Time to create page: 0.094 seconds
Powered by Kunena Forum