Z Brake before release of enable

15 Jun 2016 15:47 #76099 by jeeybee
jeeybee created the topic: Z Brake before release of enable
The Z axis of my machine drops about 2mm before the brake manages to lock the axis and I have tried some back and forth with a
classic ladder that delays the enable 0.5s after the break has been activated but it still drops as soon as I disable linuxcnc.
I hear that the servo is still enabled but the axis still goes down, is it not possible to do it like this or is there another way?

I have delayed the analogout and pid.
15 Jun 2016 16:51 #76107 by Todd Zuercher
Todd Zuercher replied the topic: Z Brake before release of enable
Is there possibly a mechanical reason for it to drop when the break is applied and the servo is disabled?

Does the servo drive have provisions to handle control of the break independent of Linuxcnc?

(I've never work worked with a Linuxcnc system with a brake.)
15 Jun 2016 17:59 #76114 by cncbasher
cncbasher replied the topic: Z Brake before release of enable
i would apply the brake function , and then look at the servo enable , you dont want to disable linuxcnc at all, as this will in effect
open the brake , and definatly does not want to be part of the switch on / off process .
15 Jun 2016 18:32 #76117 by jeeybee
jeeybee replied the topic: Z Brake before release of enable
I dont think its a mechanical reason for it to drop but I will test it tomorrow by disconnecting the break electricaly and se if it stays put then when the servos are enabled.
The servos are old fanuc drives and the brake was connected to the fanuc controlboard, not the servos (I think, it was a great while ago that I started this project)

cncbasher: what do you mean with apply the brake function, which brake function?
16 Jun 2016 04:46 - 16 Jun 2016 04:47 #76131 by kornphlake79
kornphlake79 replied the topic: Z Brake before release of enable
Once the brake is applied the servo shaft should be impossible to move, at least that is the theory, I supposed a servo could overcome the brake force for a short time before overloading the servo amp, but that shouldn't be happening in your case.

I'm guessing there is a mechanical problem, with the machine powered down and the break engaged, try turning the z axis ball screw by hand, if the screw turns with moderate effort to raise the Z axis 2 mm then stops or becomes more difficult to turn, you've got a problem with the brake. If it's convenient to remove the servo, it should be immediately obvious if the motor shaft can be turned a few degrees with minimal resistance when the brake is engaged. I'm imagining there could be a problem with the break caliper/clamp mount being loose but I've never opened up a Fanuc servo with a break so I am not certain how the brake is arranged.

I've seen some machines with a worn out brake, with a worn out brake the Z axis will slowly drop until the spindle hits something or the axis reaches it's physical travel limit, when the brake first starts to fail it may take several hours for the axis to fall an inch or two, but once the brake starts to slip the problem only gets worse. I've seen at least one machine where the brake was so worn out the normal shutdown procedure was to place a block of wood under the spindle and jog the spindle down to rest on the block of wood before switching off power, failure to follow this procedure resulted in an uncomfortable reminder.
Last Edit: 16 Jun 2016 04:47 by kornphlake79.
16 Jun 2016 08:31 #76135 by jeeybee
jeeybee replied the topic: Z Brake before release of enable
Today I tried to apply the brake manually before disabling linuxcnc and it still dropped so it seem to be a mechanical issue.
Should have tried that first :dry: would have saved me a lot of time
Thanks for the tips!
Time to create page: 0.107 seconds
Powered by Kunena Forum