7i76e and 7i73

More
29 Sep 2022 17:06 - 29 Sep 2022 17:06 #253035 by furynick
Replied by furynick on topic 7i76e and 7i73
I know this is an aged topic but I'm facing the same problem.
I connected my brand new 7i73 on my 7i76e with two different network cable and still getting communication error after trying these steps :
  • wire as explained in 7i73 manual
  • swap Tx+/Tx-
  • swap Rx+/Rx-
  • swap Tx/Rx
  • swap Tx+/Tx-
  • swap Rx+/Rx-

    I switched off 7i76 between each test but didn't started LinuxCNC.
    I guess hardware communication between 7i76e and 7i73 don't need LinuxCNC to be started, am I wrong ?

    My hal file contains sserial_port_0=20xxxx.

    Does anyone have an idea on what I'm doing wrong ?
Attachments:
Last edit: 29 Sep 2022 17:06 by furynick.

Please Log in or Create an account to join the conversation.

More
29 Sep 2022 18:49 #253043 by PCW
Replied by PCW on topic 7i76e and 7i73
1. The picture shows the TX and RX pairs swapped
(go by the colors in the 7I76 manual)
2. You need to start LinuxCNC for communications to be initiated

Please Log in or Create an account to join the conversation.

More
30 Sep 2022 16:27 #253111 by furynick
Replied by furynick on topic 7i76e and 7i73
I tried to swap Rx and Tx so they are in the wrong position on the picture.

I finally found my problem, the SSerial port must be set in mode 1 for 7i73 to work
sserial_port_0=21xxxx

I can see 7i73 pins now.

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.216 seconds
Powered by Kunena Forum