7i52s replaced ic pin continuity question

More
11 Nov 2020 21:08 #189043 by 3D-Master
The 7i52s has 4.72V at the P1 plug

Please Log in or Create an account to join the conversation.

More
11 Nov 2020 21:18 #189045 by PCW
I would guess the the driver chips are OK now

I would trace the step signals from the FPGA card to
the outputs to see whats wrong

Please Log in or Create an account to join the conversation.

More
11 Nov 2020 22:09 #189050 by 3D-Master
okay i looked at the pinout configuration using mesaflash and then used my oscilloscope to measure the header pins on the 7i80hd (upright position, P1 Header, right row is Ground and left row is bottom to top pin 0-23) but the only thing i measure is 4.6v all the time. I have a repeating program running in linuxcnc while i was measuring. Shouldnt i measure at least low and high on the direction pin?

Please Log in or Create an account to join the conversation.

More
12 Nov 2020 16:34 #189122 by 3D-Master
do the step and dir signals get send 1:1 over the 50 pin cable or do the cards communicate in a different way?

also today the y axis (com1) does work. Maybe i got it wrong when testing or something made it working.

Please Log in or Create an account to join the conversation.

More
12 Nov 2020 18:11 #189139 by PCW
3.3V level step and dir signals are sent by the FPGA card.

The 7I52S simply buffers these signals and splits them
into differential pairs

Please Log in or Create an account to join the conversation.

More
12 Nov 2020 18:37 #189142 by 3D-Master
then i wonder why i only see high signal with my oscilloscope.

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 14:41 #189335 by 3D-Master
i measured again with the 50 pin cable on the 7i80 with my multimeter and i measure constant 4.800V (its a True RMS Multimeter). I also noticed that the connector has 25 rows but the configuration pinout for P1 is from pin 1-47 (io 0-23). Could it be that some pins should be connected somewhere so the 7i80 knows there is a board connected and then sends the signals?

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 14:50 #189336 by PCW
All the even pins are ground
Pin 49 can be used to power the 7I52
There are no logical pins other than on odd pins 1..47

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 16:32 #189346 by 3D-Master
is it possible that something on the 7i80 is broken? Because when the ic burned everything shut off. I had to turn the power off and then i removed the 7i52s from the 7i80 and powered it on again and everything worked again.

as far as i have tested only COMM3 step output (TX3B and /TX3B) doesnt work (which is connected to U11 Pin 3 and 2), everything else works. (have not tested encoder inputs).

U11 Pin 1 (TX3) doesnt receive a step signal but Pin 9 (TX0) does, U2 Pin 1 (TX5),7 (TX4),9 (TX1) and 15 (TX2) do receive a step signal.

Please Log in or Create an account to join the conversation.

More
14 Nov 2020 16:33 #189347 by 3D-Master

and everything worked again.


with that i mean the 7i80 seems to work normally[/b]

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.100 seconds
Powered by Kunena Forum