Radius to end of arc differs from radius to start

15 Apr 2017 15:50 #91421 by eroberts
Thanks for the info, I ran into this same problem. I had some how set my tool length offset to zero in Fusion360, but had it as 1 in the tool table in linuxCNC. I was getting errors on the plunge spiral into a hole.

Making the tool definitions match resolved my issues. Seems obvious now.
20 Apr 2017 00:55 - 20 Apr 2017 01:01 #91684 by turbo
I was having this error again yesterday and none of the previous ways worked to solve it. I tried to simply change the arc in question to a g1 and delete the extra info, but the error just moved to the next arc. I turned on the radius option in the post processor screen and it gave me good code. I was using the standard Tormach post, so I don't see that that would be the problem. I suspect that the problem is in fusion 360, since I have compensation turned on "in computer." It shouldn't care what the radius is in the controller since it's in G40 mode.
Last edit: 20 Apr 2017 01:01 by turbo.
Moderators: Skullworks
Time to create page: 0.077 seconds
Powered by Kunena Forum