Rounding the corners off

More
06 Sep 2017 11:15 #98572 by new2linux
The geometry has sharp corners, the tool just will not follow. The geometry was created in Bobcad v29 and cut using the same software to generate cutter path, all backplots work well in Bobcad, when opening file in Linuxcnc (2.7.10) all looks ok, the tool may not travel all the way in to the corners (the color changes on the screen) of the part. I have tweaked the file to "G64 P0.015" TO "G61" w/o any significant changes. The feed rate is under 18"/min, this is mill application. At a loss as what to try, any suggestions welcomed. I have cut very simple parts and the machine cuts on size and all the way in to the corner, the file in question is not a simple shape, but is just 2d, a profile. I have read this thread: forum.linuxcnc.org/plasma-laser/33043-rounding-corners


Many,many thanks!

Please Log in or Create an account to join the conversation.

More
06 Sep 2017 12:41 #98576 by Todd Zuercher
I'm having a little problem following the description of your problem.
It would help us a lot if you posted an image or two showing the difference between the behavior you want and what you are getting.
It might also be helpful to post a copy of the g-code file that is giving you problems.

If the tool isn't following the programmed path exactly in G61 mode, then the problem is likely missed steps or something physically slipping or moving on the machine (part moving, shaft coupler slipping...)
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
06 Sep 2017 13:13 - 08 Sep 2017 10:41 #98579 by new2linux
Replied by new2linux on topic Rounding the corners off
Todd, Many thanks!

Attached are a few pics of part of the full part. If you see the bottom of the "T" and the right edges of the "E" are rounded off. These are sharp in the geometry. If you see the part on the right is cut sharp (I used original geometry cut from full profile) and this is correct. If you see the cuts on the left show the rounding, one gut is roughing pass and other is finish pass. Included is the g-code file. The file size will not allow the pic to post. I will rename g code file so it will post as well. I will try to compress pic and re-post later. I am still in talks with Bobcad to find fix or work around.




many thanks
Last edit: 08 Sep 2017 10:41 by new2linux. Reason: new pic 1.4mb too large:removed file

Please Log in or Create an account to join the conversation.

More
06 Sep 2017 18:50 #98595 by new2linux
Replied by new2linux on topic Rounding the corners off
Todd, many thanks for your help! Bobcad has a post processor with the G61 and a 2nd post with G64P0.05, I will pick the type of job/accuracy required. Have not tried it yet.

many thanks!

Please Log in or Create an account to join the conversation.

More
07 Sep 2017 11:27 #98622 by new2linux
Replied by new2linux on topic Rounding the corners off
Many thanks!
Used the G61 (this one is to slow at corner, slow but stay on path), this directs to stay on path everywhere, correct. The attached pic shows the end of the "2" & bottom of the "1" is rounded off. I will try to attach g code. The pic in question is 1.08 mb, what is the deal?

many thanks!


File Attachment:

File Name: 38201.ngc
File Size:31 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
07 Sep 2017 11:28 - 07 Sep 2017 12:08 #98623 by new2linux
Replied by new2linux on topic Rounding the corners off
Just the pic at 1.08 mb. no luck!

EDIT: Attached screenshot of linuxcnc, look at the very corners of part the red shows path of cutter.



many thanks

Edit2ndTime: The yellow is manual movement of the table.
Attachments:
Last edit: 07 Sep 2017 12:08 by new2linux.

Please Log in or Create an account to join the conversation.

More
07 Sep 2017 15:49 #98634 by new2linux
Replied by new2linux on topic Rounding the corners off
Many thanks,
This is what I believe happen to the sample above, the G61 post I used a manual set tool selection (as to increase feed rate) and that is the one. This is what I tried today, used "the lowest plastic feed rate, from table" in material selection for the stock, this cut at 60"/min max, cut to corners.

many, many thanks!

Please Log in or Create an account to join the conversation.

More
08 Sep 2017 14:11 - 08 Sep 2017 14:13 #98689 by Todd Zuercher
If you want to try making the machine move alot faster, try replacing every G61 in the file with G64P0.001.
That should significantly increase your feed rate through most corners that are not very sharp, but still maintain pretty close tolerances. You can then play with the size of the P value in the G64 command to find the right balance of speed and precision for your needs.

Running both of the G-code files you posted above in a simulation does not produce the corner rounding you showed above. (the file has G61s in it) Replacing the G61s with G64P0.001 still shows no detectable corner rounding in my simulation. In order to produce paths like you are showing I have to remove the G61s from your file and set G64 with no P tolerance.

PS: G64 with no P is the default setting when Linuxcnc is started. This is one example of why it is so important to have a proper preamble for your G-code files in order to put the machine in the correct state for properly milling your file regardless of the machine's state before you start the file.

Some codes I would consider essential for a proper preamble:
G20/G21 (T0 set the proper machine units to inches or mm.)
G17/G18/G19 (To set the proper machining plane.)
G90/G91 (Set the machine to absolute or incremental)
G40 (cutter compensation off)
G49 (Tool length compensation off)
G64Pn (Path blending with tolerance; n=some number such as 0.005)
G80 (Canned cycle cancel)
G94 (set units/minute feed mode)

Some other codes that could be very useful at the start of the file:
G7/G8/G9 (Flood or Mist coolant on/ coolant off)
G54 (or other G5x coordinate systems to set the machine coordinates as needed)
G92.2 (local coordinate system cancel)
Last edit: 08 Sep 2017 14:13 by Todd Zuercher.
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
08 Sep 2017 23:39 #98716 by andypugh
Replied by andypugh on topic Rounding the corners off
Typically this happens when you tell LincuxCNC that it can go "so" fast but should only accelerate "so" hard.

When you configured the machine, what did you base your axis acceleration values on?

What _are_ your axis acceleration limits?

LinuxCNC will do what you tell it to do. If you tell it that it can only corner at 0.001g then you will get very swoopy paths.
The following user(s) said Thank You: new2linux

Please Log in or Create an account to join the conversation.

More
09 Sep 2017 10:50 - 10 Sep 2017 11:34 #98724 by new2linux
Replied by new2linux on topic Rounding the corners off
Many thanks andypugh for all your great help for me and all the members! I have only recently cut other part with some rounding with it as well and the feed rate was way slow, I will look and try to understand all that you and Todd Zuercher have described. Both of you are complete and total gentlemen all the way thru, many, many thanks for you great help! The axis acceleration values, not altered from installed; the axis acceleration limits (I will need to check).

thanks!

edit:the max_acceleration=10.0, this was the original setting I believe. I am still working on the gcode preamble. many thanks!!
Last edit: 10 Sep 2017 11:34 by new2linux.

Please Log in or Create an account to join the conversation.

Moderators: Skullworks
Time to create page: 0.210 seconds
Powered by Kunena Forum