Mesa ethernet vs internet connection

More
17 Dec 2015 15:10 #67092 by jtc
Hi, I'm using a mesa 7i76e on the pc ethernet port, and a wifi pen to the regular internet. If I try to run the configuration with the wireless connected, i get this error.


Starting LinuxCNC...
Found file(REL): ./mesa7i76e.hal
Note: Using POSIX realtime
hm2: loading Mesa HostMot2 driver version 0.15
hm2_eth: loading Mesa AnyIO HostMot2 ethernet driver version 0.2
hm2_eth: ERROR: 192.168.1.121: Could not retrieve mac address
hm2_eth: rtapi_app_main: Resource temporarily unavailable (-11)

How can I have Internet and run the configuration at the same time? its imperative since I have to remote access to the machine.


João

Please Log in or Create an account to join the conversation.

More
17 Dec 2015 20:25 #67102 by jepler
Have you used the /etc/network/interfaces method of configuring the wired interface? This is described in the manual page, "man 9 hm2_eth" at the terminal or linuxcnc.org/docs/html/man/man9/hm2_eth.9.html online.

I believe that if you are relying on the automatic configuration known as NetworkManager, it will automatically disable a NetworkManager-controlled wired interface when activating a NetworkManager-controlled wireless interface.

Note that if your system has 1 wired and 1 wireless interface, the name of the wired interface may be "eth0" instead of "eth1" as shown in the example. The terminal command "ifconfig -a" will list the names of all installed network interfaces.

The /etc/network/interfaces file has to be edited as root, and the easiest (but not quickest) way to apply changes is to reboot after editing the file.

It may be possible to do something in NetworkManager with the graphical tools to allow both a wired and wireless interface to be active at the same time, but I am not familiar with how to do it. I hope someone more accustomed to using the GUI tools will chime in if this is possible.

Please Log in or Create an account to join the conversation.

More
17 Dec 2015 21:02 #67104 by jtc
No, I set-up the network with the graphical tool on Debian Wheezy. The 2 connections can be "enabled" at the same time (top right connections near to the clock).

I will try with this method.

João

Please Log in or Create an account to join the conversation.

More
17 Dec 2015 21:05 #67105 by PCW
I have a test machine with wireless (PCI card) and 7I76E Ethernet connection,
I dont think I had to do anything funny with net manager _but_ the 7I76E is using the 10.10.10.10
IP address to avoid overlapping the 192.168.1.xxx range (commonly used for NAT)

Please Log in or Create an account to join the conversation.

More
17 Dec 2015 21:42 #67109 by jtc

I have a test machine with wireless (PCI card) and 7I76E Ethernet connection,
I dont think I had to do anything funny with net manager _but_ the 7I76E is using the 10.10.10.10
IP address to avoid overlapping the 192.168.1.xxx range (commonly used for NAT)



probably is the reason, I have it on the same range.

Please Log in or Create an account to join the conversation.

More
17 Dec 2015 21:50 #67110 by jepler
It occurs to me that you can divide the problem into either local configuration OR hitting a corner case that hm2_eth doesn't handle:

In the terminal, "ping" the board. If you have a situation where the pings work, but hm2_eth doesn't start, then it's more likely that we should look at this as a hm2_eth bug.

If the ping doesn't work either, then it's more likely that we should look at this as a network configuration bug, and improve the documentation once we have a handle on what the fix is.

Please Log in or Create an account to join the conversation.

More
18 Dec 2015 09:04 - 18 Dec 2015 09:05 #67124 by jtc
I cant ping the board with the 2 devices enabled, so its a network configuration.


changed the ip adress of mesa 7i76e to 10.10.10.10 and selected the aproprieted jumpers to use eeprom ip, it works.

João
Last edit: 18 Dec 2015 09:05 by jtc.

Please Log in or Create an account to join the conversation.

Time to create page: 0.791 seconds
Powered by Kunena Forum