Threading on Sherline lathe

More
14 Apr 2017 07:33 #91345 by Boltonbrass
Boltonbrass created the topic: Threading on Sherline lathe
I am trying to do threading on a Sherline lathe. Here is a list of my equipment.

2 Leadshine em 705 stepper controllers
1 Pmdx 122 Bob
Omron quad. Encoder and channels
Parport built in that does spp, epp, ECP
Dayton 2m139 spindle motor
Linuxcnc 2.7.8
2 AMT dual shaft 156 oz-in stepper motors.

First question is do I have everything I need or is a vfd needed?
If so what will work with this motor? It is 165 watts.
More
18 Apr 2017 12:26 #91573 by andypugh
andypugh replied the topic: Threading on Sherline lathe
You shouldn't need anything else.

Have a look here: forum.linuxcnc.org/26-turning/30181-sher...rsion?start=20#86760
More
18 Apr 2017 12:35 #91575 by Boltonbrass
Boltonbrass replied the topic: Threading on Sherline lathe
The lathe is trying to thread but it is still not synching correctly because I had set the program to do 4 tpi and it looked like 80 tpi. I will upload my Hal and ini files here today. My latency is like 19500 me if that helps. All help appreciated.
More
18 Apr 2017 22:18 #91611 by Boltonbrass
Boltonbrass replied the topic: Threading on Sherline lathe

File Attachment:

File Name: 4400.hal
File Size:3 KB

File Attachment:

File Name: 4400.ini
File Size:2 KB
Attachments:
More
19 Apr 2017 09:48 #91625 by andypugh
andypugh replied the topic: Threading on Sherline lathe
Does motion.spindle-revs increase by 1.00 if you rotate the spindle forwards by hand?

4tpi on a Sherline seems ambitious. Are you sure that the Z axis can move fast enough to follow a 4TPI thread at the selected spindle speed?
More
20 Apr 2017 14:52 - 20 Apr 2017 14:53 #91690 by Boltonbrass
Boltonbrass replied the topic: Threading on Sherline lathe
Yes the it increases by one on the halscope when I turn it by hand.
Last Edit: 20 Apr 2017 14:53 by Boltonbrass.
More
20 Apr 2017 16:10 #91697 by andypugh
andypugh replied the topic: Threading on Sherline lathe
And the second part of the question?
More
20 Apr 2017 16:48 #91699 by Boltonbrass
Boltonbrass replied the topic: Threading on Sherline lathe
Not sure if it is able to do 4 tpi. For what I am doing I have to have 40 tpi internally and externally. I tried threading again, and I set the spindle speed at roughly 1000 rpm. The tool engaged engaged the part at the same speed it jogged to the part from the home position. It simply is not synching up to spindle.
More
20 Apr 2017 17:21 #91704 by andypugh
andypugh replied the topic: Threading on Sherline lathe

Boltonbrass wrote: Not sure if it is able to do 4 tpi. For what I am doing I have to have 40 tpi internally and externally. I tried threading again, and I set the spindle speed at roughly 1000 rpm. The tool engaged engaged the part at the same speed it jogged to the part from the home position. It simply is not synching up to spindle.


Max velocity in the INI file is 0.475 in/sec.

40 tpi @ 1000 rpm = 0.417 in/sec.

So the machine should be able to do 40 tpi @ 1000 rpm. How accurate is your spindle speed? It would not have to be much faster than commanded for the system to be unable to keep up.

It might be that the Z-axis can never actually "catch" the commanded position.
More
21 Apr 2017 14:39 #91789 by Boltonbrass
Boltonbrass replied the topic: Threading on Sherline lathe
Andy, I have just successfully made 40tpi work. Thanks for all the help. My problem was trying to use g76 instead of g33. So basically I was already there.
My slowest rpm is basically 1300 so I will have to change motors, so I believe I am good to go. You are a real trooper and I thank you for your help.
Time to create page: 0.224 seconds
Powered by Kunena Forum