programmed depths are shallow

More
15 Jun 2018 15:35 #112409 by dhanger
Hello group-

For the last month or so I've developed an issue with my mill leaving all my programmed depths .003-.004 shallow. I've had LinuxCNC set up and running on this machine for over a year now without having this problem before, so I'm wondering if I may have set some parameter wrong inadvertently, although for the life of me I don't know what it could be.

I've been programming industrial CNC's for 25 years and built/reconfigured my own machines for the last 10, so this isn't some dumb rookie problem. I've chased down all the usual suspects and come up with nothing, which leads me to think it's something I've changed in LinuxCNC, but what, I don't know. One thing I've noticed that may be a clue--when I have a Z move to feed to depth, for example a recent program, feed to z-.050 and then feed in X, it will feed to z-.0476 first, then on the X move it will feed down to -.050 along with the X move, but still it's not cutting to depth.

Any clues for what to look for?

Dan
LinuxCNC 2.7
More
16 Jun 2018 20:28 #112494 by joekline9
I think it has to do with the trajectory planner settings.
I had same issue a while back. I'll see if I can find how I fixed it.
More
16 Jun 2018 21:23 #112496 by joekline9
Version 2.7 has new Trajectory planner.
Try putting:
G64 P.0001
at the top of your G code file.
For more info check docs under G64.
More
17 Jun 2018 21:14 #112514 by dhanger
Hmm. I've been using G64 P.001 long before this problem came up.

Thanks,
Dan
More
24 Jun 2018 10:09 #112816 by andypugh
Wh
at you describe sounds like PID settings, but I can't see why they would change.
Normally I would suggest tool table, but assume you checked that.
More
25 Jun 2018 14:04 #112846 by dhanger
This is a stepper driven mill, so PID wouldn't apply. Yeah, checked the tool table several times, especially since I use TLO's a lot.

I've been trying to trace back what I might have done at the time I started having this problem. Only thing I can think of is that I did a bunch of re-wiring in the cabinet at the time (this is an old machine that I ripped out and replaced most of the electronics and had a rat's nest needing attention). In all my setups I've checked and re-checked TLO's, etc., but when the mill is running it all goes bad. I started wondering if maybe when I did the re-wiring I may have set up a situation where the Z axis signals may be affected by some EMI interference. Seems like a long shot, and everything worked well with the rat's nest. I haven't had a chance to really look at that, but a quick glance showed the motor cable and driver was well away from anything obvious.

It's very frustrating--I've been making compensations in the Z axis to work around it, but every once in a while the problem goes away and cuts as it should. Haven't ruined anything important yet, but I can feel it coming.....

Thanks,
Dan
More
25 Jun 2018 15:03 #112850 by andypugh
If you are using Mesa cards then there might be a PID in the HAL even with steppers.
Time to create page: 0.077 seconds
Powered by Kunena Forum