Spindle on or off, no speed adjustment

More
24 Jun 2018 23:20 #112826 by javelin
Hello guys..

I went back with a huanyang vfd and now I am getting an odd occurrence.

It is setup via modbus so PD 001 and 2 are both set to 2. Modbus is communicating as the spindle will turn on. After turning on there is no speed control whatsoever. I can run forward on, reverse on, and off. Thats all. I will post the custom hal here and maybe someone can help spot my stupid moment.

loadusr -W hy_vfd -d /dev/ttyUSB0

net vfd-comms halui.machine.is-on => hy_vfd.enable
net spindle-fwd motion.spindle-forward => hy_vfd.spindle-forward
net spindle-reverse motion.spindle-reverse => hy_vfd.spindle-reverse
net spindle-speed-cmd motion.spindle-speed-out-abs => hy_vfd.speed-command
net spindle-on motion.spindle-on => hy_vfd.spindle-on
net spindle-at-speed motion.spindle-at-speed => hy_vfd.spindle-at-speed


For kicks bot Hal and Custom Hals are attached

File Attachment:

File Name: machinetes...6-24.hal
File Size:10 KB

File Attachment:

File Name: custom_2018-06-24.hal
File Size:1 KB


Thanks guys.
Attachments:
More
24 Jun 2018 23:42 #112827 by javelin
Amendment to my last post. There is still a problem but its not with linuxcnc. If anyone has any experience with this setting please chime in.

PD011 is a minimum limit setting which I had set to 120 for safety of the spindle. In other words it starts at this minimum speed. Yet when you start the spindle in linuxcnc it not only starts at this minimum, it will not increase nor decrease in speed. Its locked in.

When I set PD011 to 000.00 I can then start linuxcnc and adjust the speed as expected through axis, increase to my desired speed and all is well with the world.

Yet I would like to have a minimum speed setting in order to help prevent accidentally smoking the motor at too low of a speed. Anyone have any suggestions?
More
26 Jun 2018 06:21 - 26 Jun 2018 06:22 #112867 by curtisa

net spindle-speed-cmd motion.spindle-speed-out-abs => hy_vfd.speed-command


I think the above line shoud be:

net spindle-cmd-rpm-abs => hy_vfd.speed-command


PD011 is a minimum limit setting which I had set to 120 for safety of the spindle. In other words it starts at this minimum speed. Yet when you start the spindle in linuxcnc it not only starts at this minimum, it will not increase nor decrease in speed. Its locked in.

When I set PD011 to 000.00 I can then start linuxcnc and adjust the speed as expected through axis, increase to my desired speed and all is well with the world.

Yet I would like to have a minimum speed setting in order to help prevent accidentally smoking the motor at too low of a speed. Anyone have any suggestions?


PD011 sets the minimum spindle RPM of the spindle in Hz (not in RPM). So if your spindle is spec'ed to do 24K RPM at 400Hz, a setting of 120Hz is equivalent to 7200PM. This is a safe minimum limit for an air-cooled spindle to prevent overheating at low RPM.

Chances are that with PD011 = 120, you're not increasing the RPM in Axis enough until you pass the 7200 RPM mark - it'll take a lot of mouse clicks on the '+' button to get there, which may give the impression that the RPM isn't being adjusted. When manually controlling the spinle, Axis always starts at 0 RPM, so you have to hammer away on the '+' button a lot until you exceed the minimum RPM threshold, after which the VFD will start accepting each subsequent RPM increment request.

With PD011 = 120, try bringing up the MDI window and typing:

M3 S10000

Based on your observation that the spinde speed appears to be controllable when PD011 = 0, my guess is that the VFD will ramp up to 10K RPM just fine.
Last edit: 26 Jun 2018 06:22 by curtisa.
More
26 Jun 2018 18:10 - 26 Jun 2018 18:11 #112899 by javelin
This was exactly the case. I kept clicking the + for the motor speed and after axis = 120 or greater the speed did pick up in line with linuxcnc. So all is good. I run a water cooled spindle yet for these motors they do not like low speeds. I know I could take the water cooled down a little less than 120, but I feel safe there lol.

As for the hal line adjustment. I tried it but with that I lost speed control. I went back with my original line and all is fine when running that.

I dont know if its possible but I may poke around and see if I can find a way to have linuxcnc start the spindle speed equal to that of the vfd for the sake of simplicity. Its not an important feature right now but something on the back burner.

Thanks again for the help!
Last edit: 26 Jun 2018 18:11 by javelin.
Time to create page: 0.070 seconds
Powered by Kunena Forum