radius to end of arc differs from radius to start error

More
23 Aug 2018 02:47 - 23 Aug 2018 12:21 #116469 by stidrvr
I need a little help. I'm using Fusion 360 for CAM and the EMC2 post processor profile. I'm getting this error and everything I've found on Fusions forum directs me to the LinuxCNC forum to a post explaining but the details in how to fix it aren't geared towards noobs.

forum.linuxcnc.org/20-g-code/28689-arc-tolerance?start=0

From what I can tell I need to edit the TOLERANCE_INCH line to increase the decimal places. The file that needs to be edited in the interp_internal.cc its supposed to be located in src/emc/rs274ngc/ folder within linuxcnc directory but the only folder in there are configs and nc_files.
Last edit: 23 Aug 2018 12:21 by stidrvr. Reason: Updated link

Please Log in or Create an account to join the conversation.

More
23 Aug 2018 04:00 #116472 by curtisa
The folder listed is part of the source code on github, not as part of your local installation of LinuxCNC.

Looks like the post you've linked to is talking about a patch to be applied to the interp_internal.cc file to allow specifying a new setting called TOLERANCE_INCH in your INI file. As such, you'd need to recompile LinuxCNC from scratch using the patch to implement it.

Have you tried some of the other suggestions usually leveled at this problem, namely getting the Fusion 360 post-processor to generate G-code with more decimal points of accuracy?

Please Log in or Create an account to join the conversation.

More
23 Aug 2018 12:20 - 23 Aug 2018 12:25 #116484 by stidrvr
Hi curtisa,

Well that makes a little more sense. Whats odd is that from what I could tell, this was supposes to be implemented in 2.7 which is what I'm running.

This arc tolerance issue is fixed in the just-released 2.7.0~pre4.


forum.linuxcnc.org/38-general-linuxcnc-q...al-debounce?start=10

Well, anyway, I did increase the tolerance from 0.01 to 0.0001 in fusion which is what I thought was suppose to increase the decimal places. I looked at the program that's having the issues and still only see out to four decimal places. I try and do a little more digging and see if what I'm doing is correct.
Last edit: 23 Aug 2018 12:25 by stidrvr. Reason: Added link for update comment

Please Log in or Create an account to join the conversation.

More
23 Aug 2018 22:29 #116510 by curtisa
The other option I've had success with when I get that error is to output the Gcode in mm rather than inches. Four decimal points in metric offers more resolution than four decimal points in imperial.

But usually every time I get the arc tolerance error I just increase the resolution of the post processor output and it goes away.

There isn't a TOLERANCE_INCH setting in my INI file (2.7.12) to adjust, nor does the documentation mention that setting in the INI file. Of course, it may be there but the docs haven't been updated to reflect it? You could try adding:

TOLERANCE_INCH = 0.01

...under the [RS274NGC] section in your INI file and see if it makes a difference, and/or try playing with different values. LinuxCNC will either spit out an error if it doesn't like seeing that line there or just ignore it if it doesn't understand it.

Please Log in or Create an account to join the conversation.

More
24 Aug 2018 11:15 #116530 by andypugh
See this message here:
forum.linuxcnc.org/20-g-code/28689-arc-t...ance?start=30#116522

The setting seems to exist, but is undocumented and called something else...

Please Log in or Create an account to join the conversation.

More
24 Aug 2018 11:17 #116531 by andypugh
But bear in mind that the problem might be real.Rradius / diameter settings or havign arc centres in absolute mode can cause the same problem.

Also consider what the machine is expected to do in situations where the start, end and centre coordinates do not in fact define a circle. What should the controller do?

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum