Problems loading LCNC after changing wheezy repositories

More
11 May 2019 09:03 #133439 by aaron
Hi All
I just tried to change the repository for my old debian wheezy system and now LinuxCNC will not work. I have attached the error message.
I understand that debian wheezy is no longer supported officially is this right?
I need to know what repositories I should use.
the ones I have now

Attachment not found

Attachment not found

are:

deb archive.debian.org/debian wheezy main
deb-src archive.debian.org/debian wheezy main
deb linuxcnc.org/ wheezy base 2.7-uspace
deb-src linuxcnc.org/ wheezy base 2.7-uspace

File Attachment:

File Name: Errormessa....txt.zip
File Size:13 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
11 May 2019 09:10 #133441 by aaron
Sorry. I don't seem to be able to attach the error message. Here are the first sections, can they help diagnose problem?

Print file information:
RUN_IN_PLACE=no
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/usr/bin
LINUXCNC_TCL_DIR=/usr/lib/tcltk/linuxcnc
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/usr/lib/linuxcnc/modules
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/usr/share/linuxcnc/tcl/msgs
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.5
LINUXCNC - 2.7.14
Machine configuration directory is '/home/aaron/linuxcnc/configs/foam_xxyz'
Machine configuration file is 'foam_xxyz.ini'
INIFILE=/home/aaron/linuxcnc/configs/foam_xxyz/foam_xxyz.ini
PARAMETER_FILE=linuxcnc.var
TASK=milltask
HALUI=
DISPLAY=axis
Starting LinuxCNC...
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Found file(REL): ./foam_xxyz.hal
Shutting down and cleaning up LinuxCNC...
Killing task linuxcncsvr, PID=3889
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments

Debug file information:
Note: Using POSIX non-realtime
Unknown parameter `coordinates=XYZX'
./foam_xxyz.hal:4: waitpid failed /usr/bin/rtapi_app trivkins
./foam_xxyz.hal:4: /usr/bin/rtapi_app exited without becoming ready
./foam_xxyz.hal:4: insmod for trivkins failed, returned -1
3889
PID TTY STAT TIME COMMAND
Stopping realtime threads
Unloading hal components
Note: Using POSIX non-realtime

Thanks again
Aaron

Please Log in or Create an account to join the conversation.

More
15 May 2019 11:58 #133831 by andypugh

aaron wrote: Sorry. I don't seem to be able to attach the error message. Here are the first sections, can they help diagnose problem?
Note: Using POSIX non-realtime
Unknown parameter `coordinates=XYZX'n


Two things.

1) You seem to not be running under a realtime kernel
What does "uname -a" say?
2) You seem to be using a 2.8 configuration with LinuxCNC 2.7.
Where did the config file come from?

Please Log in or Create an account to join the conversation.

More
15 May 2019 18:12 - 16 May 2019 08:18 #133870 by InMyDarkestHour
Last edit: 16 May 2019 08:18 by InMyDarkestHour.

Please Log in or Create an account to join the conversation.

More
15 May 2019 18:33 #133878 by andypugh
I don't think it is exactly the same question.

I think what has happened here is a (correct) change to the Wheezy archive, but a mistaken change from the LinuxCNC buildbot 2.8 version of LinuxCNC to the released 2.7 LinuxCNC repository.

Please Log in or Create an account to join the conversation.

More
15 May 2019 19:49 - 16 May 2019 08:18 #133891 by InMyDarkestHour
Last edit: 16 May 2019 08:18 by InMyDarkestHour.

Please Log in or Create an account to join the conversation.

Time to create page: 0.083 seconds
Powered by Kunena Forum