Ditching Linux CNC & why

More
14 May 2019 21:29 - 16 May 2019 08:21 #133789 by InMyDarkestHour
meh
Last edit: 16 May 2019 08:21 by InMyDarkestHour. Reason: ARGHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH

Please Log in or Create an account to join the conversation.

More
14 May 2019 23:39 #133792 by islander261
I must say that if the OP wants a quick fix this is not the correct place to be. When I started on my plasma machine it was a working commercial unit. I knew or thought I knew exactly how I wanted it to operate. So I bought a Mesa THCad card and was going to use a small micro card to read its output into a PC and use the commercial program. Well I started reading about LinuxCNC and saw the Gmoccapy plasma examples and thought this is it! Well it took me 2 1/2 years to build a working system with all the custom bells and whistles. The free PC hardware I had was not happy with the iso available at the time and wouldn't work for more the a few minutes. I finally tried Linux Mint Debian Edition 2 and it would run on my hardware (still does). Now the problem was no RT. So I searched and search some more to find instructions on patching the kernel for RT. It only took about 6 or 7 maybe more tries before I got it to work. Of course by then I needed the master branch because of my dual drive gantry. More figuring out how the download and build. Now that wonderful Gmoccapy plasma example has no guts behind the GUI, off into first getting the correct Glade downloaded and configured then to building new screens. I am not a programmer or IT guy so along the way I got to learn rudimentary Python reading then parroting and actually building the handlers for the Glade panels. I will not bore you with the adventures into external offsets land (now part of the master branch) but this ate up several months of THC trials time. When I was finally happy with the operation of my system I got rid of the commercial controller and THC. Then six months later this guy in Oz starts posting about his Plasmac branch for running a plasma cutter. Because I had created such a can of code worms my system wasn't really maintainable or easy to change. I needed a new feature and couldn't get it work work. I cloned the Plasmac branch and started to adapt it to my machine. I found I really liked how the THC and other plasma specific stuff worked. Thanks to Phill C. I now have a really nice CNC plasma cutting machine using his Plasmac branch. All of this has taken about 3 1/2 years to date but I have really nice custom CNC plasma machine that cuts as good or better than machines that cost many many thousands of dollars more. I guess the moral of this story is that unless YOU are willing to put in the time and effort to build a custom machine controller this isn't the place to be. Everyone here was more than helpful and patient when helping me along the way. If all else fails RTFM until you understand how the feature works!

John
The following user(s) said Thank You: Clive s, rodw

Please Log in or Create an account to join the conversation.

More
15 May 2019 01:15 #133799 by rodw
Replied by rodw on topic Ditching Linux CNC & why

InMyDarkestHour wrote: If you want to see how uncaring and unable to appreciate effort check out all the trolling on Rod's Spaceship build......I'm pretty sure he cries himself to sleep every night from all the trolling.

(I figure you'd get the sarcasm Rod)


I had trouble reading that at my age so made it a bit bigger.

It take a bit to get me upset. A few years earlier on a failed attempt, I had troubles with a parallel port config which I eventually dismantled , I was just gobsmacked by the help people here willingly gave me to get my parallel port working. But I never did master it becasue I'd connected it to the motherboard wrong. In all honesty, the help I've received on this forum has been amazing. The hand holding and advice from the very first post was something I'd never experienced before on any forum. But you have to ask the right questions and I've found its always best to give it a go first.Clearly you did that.

We are still here waiting to help but we need to see some of your config rather than a simple "My VFD does not work". You have not even told us which part is broken. Is it a modbus control or are you using a potentiometer? Sadly we can't make house calls.

Please Log in or Create an account to join the conversation.

Time to create page: 0.109 seconds
Powered by Kunena Forum