Robot Arm not move in World mode

More
15 May 2019 07:00 #133823 by M.O.
Hello

i built a robot arm with three axes. See Picture.


I control it with the Mesacards 6i25+7i76. I tried the vismach config with genserkins. All three axes alone drive very well but if i try the world mode nothing happens. I homed the axes but nothing happens.

If i try the command "dmesg" in a terminal the following error is be shown. What this means?

I Need help because i tried so much but nothing help

I send also my INI and my HAL
Attachments:

Please Log in or Create an account to join the conversation.

More
15 May 2019 11:13 - 15 May 2019 11:19 #133826 by pl7i92
this is ABC not XYZ

use the puma560 and it will work in world mode

THE error complaqins on Joints
the HAL includes AXIS there is a MISSMTch on Version of Kins

Please tell us what verison and operation system you using Wheezy Ubuntu debian
2.7.x or 2.8.x

this Combination of files is not working
Last edit: 15 May 2019 11:19 by pl7i92.

Please Log in or Create an account to join the conversation.

More
15 May 2019 11:28 - 15 May 2019 12:18 #133829 by M.O.
I use Debian GNU/Linux 7.11(wheezy)
Linux CNC Version 2.7.11

I use the Puma 560 but it don´t work

What du you mean with"This combination of files is not working"?

The INI and the HAL under this post is the example config of PUMA560 which i find on my PC. But i think there are mistakes in it
Attachments:
Last edit: 15 May 2019 12:18 by M.O..

Please Log in or Create an account to join the conversation.

More
16 May 2019 13:27 #133968 by M.O.
i tried it now with JOINTS but if i want open the GUI it shows the Error: Joint.0.motor-pos-cmd not exist. But i don´t understand why.

is there a mistake in my INI or my HAl?
Attachments:

Please Log in or Create an account to join the conversation.

More
16 May 2019 13:58 #133972 by PCW
1. You would need LinuxCNC 2.8 to have joint.0.motor-pos-cmd
2. If that "Error: Joint.0.motor-pos-cmd" is the actual error, you have Joint capitalized
which would not work

Please Log in or Create an account to join the conversation.

More
16 May 2019 14:06 #133974 by M.O.
Is there a possibility to Control the Robot arm with Linux cnc 2.7.14.?

Please Log in or Create an account to join the conversation.

More
16 May 2019 14:22 #133978 by PCW
Yes, but note that many of motions signal names have changed between 2.7 and 2.8
and joint.0.motor-pos-cmd is a LinuxCNC 2.8 pin name.

I do suspect that LinuxCNC 2.8 would be a better choice for robotics since it makes a clear distinction between joints and axis

Please Log in or Create an account to join the conversation.

More
21 May 2019 08:02 #134453 by M.O.
I read a lot about Linux cnc 2.8 and it is not a official Edition of Linux cnc.

I would like to try it with 2.7.14 but i have still no idea why my world mode not run.

Any ideas please?

Please Log in or Create an account to join the conversation.

More
21 May 2019 13:42 #134477 by Todd Zuercher
Even though 2.8 is still under development, it is still a very usable program. I think it may be very close to being released. I would be surprised if it is not released before the end of the year. (However I am not one of the developers,)

Please Log in or Create an account to join the conversation.

More
22 May 2019 13:57 #134579 by M.O.
i have updated to 2.8

after Homing my Axes it shows an error "KinematicsInverse failed".

I think my D-H Parameters are wrong or?

Please Log in or Create an account to join the conversation.

Time to create page: 0.234 seconds
Powered by Kunena Forum