Y Axis missing steps on 300K+ line program

More
14 Jul 2020 21:27 - 14 Jul 2020 21:30 #174665 by jm82792
I have a 300K+ line program and have been noticing 2mm of Y drift every hour or so.
I've changed out the stepper, cranked up the G540's current, decreased the speed/accel to a crawl, increased step time by 1000ns from the G540 Step Conf default,and still no luck.

Recently updated everything to 2.7 and originally was 2.6 but rarely used the machine till recently.
I actually posted about this 3 years ago, I changed the motor to another spare axis on the G540, and never had an issue for another 50+ hours of use with 100K sized programs..
(Cannot rule out the update but suspect that's not the case)

I've seen absolutely no faults on the Z or X axis at all--I've checked everything over mechanically many times and the Y axis is actually the smoothest axis on my machine!

Computer is a J1900 with 4 gigs of ram and sata dom. Wiring seems pretty decent, PSU is well sized, motors aren't hot, etc.

Can larger files cause weird issues? Seems to never happen on short programs.
I have relatively fine resolution coupled with G64 but perhaps when it shifts from a raster pas to moving the Y axis over one increment it occasionally skips for an unknown reason?

I've got a Mesa 6i25 I never seriously tried to get working. Would that somehow help?
I'm postulating it has to do with larger files but such a position error only on a single axis disagrees with my assesment.
Last edit: 14 Jul 2020 21:30 by jm82792.

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 08:25 #174698 by tommylight
What reduction? What is the step rate per machine unit ?
The following user(s) said Thank You: jm82792

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 15:38 - 15 Jul 2020 15:41 #174756 by jm82792
It's a 6040 machine with 5 mm pitch ballscrews but I threw out all the wiring, control box, and retrofitted it with a G540. It has new ballscrew support bearings and the Y axis in particular moves very smoothly with no perceivable play (easily backdrives very smoothly for what it is) compared to my other acme drive machine that has an identical clone of the same electronics. It has maybe 60-100 hours on it and I had a similar issue years back--but somehow it went away, and I never looked back till recently when started using my "backup" machine much more frequently.

No reduction just 5mm per turn, X/Z axis use the same settings with no issues (no banding, over, or under cuts), and there's ample reserve as the accel is only 300mm^2 for the Y axis when it can readily go 600mm^2 or higher. Speed is set to about 3000mm and the motors have a ton of torque--48V, lower inductance (5mh ish), and everything is tightly secured.

When testing it in Step Conf I see no issues when running a +/- 15mm axis test on the Y with the aforementioned settings.... I even changed it briefly to 1mm, cranked the accel up to around 2000mm^2, and the table shook--something would eventually break but position wasn't even lost during that minute or two of abuse.

I'm suspecting the overhead of running LinuxCNC with such a program is the issue or the computer is getting old.

Latency is around 6000 and I have it set to 25,000 as I don't need insanely fast rapids plus I like overhead reserve. I'll likely swap it out with its clone and see what happens but that makes me nervous as I don't have a third computer if the second one somehow gets damaged or "messed up" somehow.
Last edit: 15 Jul 2020 15:41 by jm82792.

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 16:23 #174761 by tommylight
3D printer ?
If at all possible, change the X and Y axis by moving motor connectors, that is easy, test and report back.
Please do power of the G540 before removing connectors.

Please Log in or Create an account to join the conversation.

More
15 Jul 2020 17:43 - 15 Jul 2020 17:50 #174764 by jm82792
No sir it's just a 6040 CNC import doing raster finishing and I run a 0.8KW spindle on it which is correctly grounded.

I suspected the VFD could do it but it is only happening on a single axis which makes me think otherwise especially with shielded cable which is grounded on one end only, with no ground loops, machine frame is grounded through spindle, and I verified ground carries from frame to the ground on the plug.

Stepper cable shields aren't grounded but it did work well beforehand. Other machine is setup the same (600+ hours of use--MDF frame) but uses a Delta VFD and not a Sunfar/Random import unit but uses same motherboard, etc.

So far I've done 1 hour of the StepConf movement testing with +/-15mm and had absolutely no loss of movement. The loss of position appears to only happen with a large program but I've not ruled out an intermittent electrical connection fault fully.

Whenever I remove connections I throw on the EStop switch--I know G540's are more tolerant but I do recall the older days where drivers would blow easily and resonance was a key concern.

I'll certainly do the axis swap test and run the entire program to see what happens.
I've also got an external motion card and software arriving soon--I dread Window's bloat but if my daily driver i7 desktop and my desire to kill the problem succeeds then I'll retire/blame the J1900 board for starters.
Last edit: 15 Jul 2020 17:50 by jm82792.

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 01:32 #174799 by jm82792
I somehow managed to get the 5i25 working (easy but took some time) and the motors sound happier, however, I still see the same issue, and therefore I am suspecting it's the G540. I swapped to the 4th axis (test in progress), and will also swap the XY connectors on my next test run.

I was concerned the 3.3v from the parallel port was causing issues or the pulse train wasn't "good" but I think I've effectively eliminated both concerns.

I did have a weird issues once where my screen ghosted and duplicated several times with the mesa card--everything was working fine (continued to move) but I couldn't resolve it without a restart. Still the results are a few mm of position loss and it's not an erratic thing--so I'll keep testing and keep you posted.

If things were erratic I'd blame the motherboard and at the moment I want to blame the G540 but time will tell.

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 15:27 - 16 Jul 2020 15:30 #174860 by jm82792
I tried the 4th axis again but with the Mesa card.
It appears everything is working and it even got me to figure out the 6i25. It's not that difficult but a basic set of steps would help as it's been years since I've done much with Linux.

I'd like to attribute it to either a slightly blown driver and/or 3.3v parallel port voltages coupled with step timing on the G540--which some people found to be of issue which I found through a few hours of research. I did attempt to increase step hold time.. I think it's QC of drivers couple with the lower yet still spec sheet voltage.

I do have a new complication which occurs after 30-45 minutes of use and everything works as I've memorized the keyboard shortcuts but this is less than ideal. I did read I shouldn't use more than a 1gb of ram (?) and I recently upped it to 4gb so perhaps I should swap it back to 2gb, should see if I can update drivers with the integrated drivers, and/or throw in a GT730 to see if that'll fix the issue.

Can't think that the integrated graphics would be going out and I do not within the GUI allow AXIS to draw everything as that slows the FPS/response time down.

Last edit: 16 Jul 2020 15:30 by jm82792.

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 16:20 #174863 by tommylight
That looks like a syncing issue, so first check the cable and make sure it is working properly and properly inserted.
Had plenty of such issues with HDMI cables, never with DVI except when not properly seated.
And you can have as much memory as you can cram into it. Where did you get the 1Gb thingy ? That is not correct.

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 16:44 #174865 by jm82792
Thank you for clarifying my problem.
I'll try to get a DVI or SUB-D connected to it as I attempted to once there was a syncing issue but perhaps it needs this change to occur before boot.

I think I misinterpreted this "384 MB of RAM (512 MB up to 1 GB recommended)" from the minimum requirements page.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
16 Jul 2020 17:59 #174871 by tommylight
DVI or Display port if you have them, Sub-D is analogue so the picture is not as sharp as with the other connections.

Please Log in or Create an account to join the conversation.

Time to create page: 0.180 seconds
Powered by Kunena Forum