MPG not working with 7i76

More
25 Oct 2021 11:24 - 25 Oct 2021 11:26 #224245 by bevins
I don't know why but for the life of me I cannot get this working. The mpg came from a machine that was working with a 7i76.Can someone take a look and see if I am not    doing something obvious?

Warning: Spoiler!
Attachments:
Last edit: 25 Oct 2021 11:26 by bevins.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 11:27 #224246 by bevins
Replied by bevins on topic MPG not working with 7i76
Cant get any counts. I even tried putting pullups with 1K to 5v. still nothing. I know the mpg is good as I used it for testing another machine.

 
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 11:58 - 25 Oct 2021 12:10 #224249 by bevins
Replied by bevins on topic MPG not working with 7i76
AHH... /HeadSlap..... I didn't check the jumpers. They are probably in Differential mode. I think I need single ended as I only use A and B.

Does jumpers W4 W5 W6 affect the encA and encB also or just the enc0 and enc1?
The thc is working with thcad so I dont want to mess with encA
Last edit: 25 Oct 2021 12:10 by bevins.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 12:56 #224257 by bevins
Replied by bevins on topic MPG not working with 7i76
so the jumpers are to the left so they are in single-ended mode.
 

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 14:54 #224269 by PCW
Replied by PCW on topic MPG not working with 7i76
Only the high speed encoder input (TB3 pins 7 .. 15) is affected by the single/differential mode jumpers .

The 7I76 MPG inputs (on TB5 pins 1,2,3,4) only support single ended inputs

TB5:

1 MPG Enc0A
2 MPG Enc0B
3 MPG Enc1A
4 MPG Enc1B

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 15:02 - 25 Oct 2021 15:16 #224271 by bevins
Replied by bevins on topic MPG not working with 7i76

Only the high speed encoder input (TB3 pins 7 .. 15) is affected by the single/differential mode jumpers .

The 7I76 MPG inputs (on TB5 pins 1,2,3,4) only support single ended inputs

TB5:

1 MPG Enc0A
2 MPG Enc0B
3 MPG Enc1A
4 MPG Enc1B

 

ok so I am good there. The thc is working so I don't have to worry about those. So I am not getting anything on the mpg pins.
I am using the 5v from TB2 for the mpg. Is this an acceptable behaviour? Are they isolated so where it has no ref to the inputs 16/17? Should I connect directly to the 5v power supply for the mpg? I also have puulups to the 5V power supply.
Last edit: 25 Oct 2021 15:16 by bevins.

Please Log in or Create an account to join the conversation.

More
25 Oct 2021 16:46 #224283 by PCW
Replied by PCW on topic MPG not working with 7i76
You need to have the 5V MPG power ground connected to the field power common
because the MPG inputs on TB5 have field power common as their ground reference

Please Log in or Create an account to join the conversation.

Time to create page: 0.192 seconds
Powered by Kunena Forum