Second EMC2 config question

More
13 May 2011 20:51 - 13 May 2011 20:51 #9792 by jhtitan
jhtitan created the topic: Second EMC2 config question
OK so I had an idea, I use my CNC mostly for cutting RC planes and plane parts. I wanted to try some hotwire cutting. I was trying to figure out a way to draw in the Y-Z plane in 2d instead I decided it would be easier to draw in XY plane but re-configure a second mill in EMC and re-map my motors so that X = Z and Y=X and Z=Y I did the config and got everything working in the test of each axis. but when I try to run the new config i get an error and it shuts down EMC

can I not have 2 different config's of the same mill? or can you only have one config per port? not sure why everything seems to work in step config but not when I try to run EMC. The original config still works fine.

here is the error:


Print file information:
RUN_IN_PLACE=no
EMC2_DIR=
EMC2_BIN_DIR=/usr/bin
EMC2_TCL_DIR=/usr/share/emc/tcl
EMC2_SCRIPT_DIR=
EMC2_RTLIB_DIR=/usr/realtime-2.6.32-122-rtai/modules/emc2
EMC2_CONFIG_DIR=
EMC2_LANG_DIR=/usr/share/emc/tcl/msgs
INIVAR=inivar
HALCMD=halcmd
EMC2_EMCSH=/usr/bin/wish8.5
EMC2 - 2.4.6
Machine configuration directory is '/home/emc/emc2/configs/Hot Wire'
Machine configuration file is 'Hot Wire.ini'
INIFILE=/home/emc/emc2/configs/Hot Wire/Hot Wire.ini
PARAMETER_FILE=emc.var
EMCMOT=motmod
EMCIO=io
TASK=milltask
HALUI=
DISPLAY=axis
NML_FILE=
Starting EMC2...
Starting EMC2 server program: emcsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting EMC2 IO program: io
Shutting down and cleaning up EMC2...
Killing task emcsvr, PID=1881
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments
Cleanup done

Debug file information:
Could not open command file 'Hot'
1881
PID TTY STAT TIME COMMAND
Stopping realtime threads
Unloading hal components

Kernel message information:
[ 222.826567] I-pipe: Domain RTAI registered.
[ 222.826579] RTAI[hal]: <3.8.1> mounted over IPIPE-NOTHREADS 2.6-03.
[ 222.826585] RTAI[hal]: compiled with gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) .
[ 222.826655] RTAI[hal]: mounted (IPIPE-NOTHREADS, IMMEDIATE (INTERNAL IRQs DISPATCHED), ISOL_CPUS_MASK: 0).
[ 222.826661] PIPELINE layers:
[ 222.826666] fc995e20 9ac15d93 RTAI 200
[ 222.826671] c085cb20 0 Linux 100
[ 222.853772] RTAI[malloc]: global heap size = 2097152 bytes, <BSD>.
[ 222.853998] RTAI[sched]: IMMEDIATE, MP, USER/KERNEL SPACE: <with RTAI OWN KTASKs>, kstacks pool size = 524288 bytes.
[ 222.854006] RTAI[sched]: hard timer type/freq = APIC/12476550(Hz); default timing: periodic; linear timed lists.
[ 222.854011] RTAI[sched]: Linux timer freq = 250 (Hz), TimeBase freq = 2994054000 hz.
[ 222.854015] RTAI[sched]: timer setup = 999 ns, resched latency = 2943 ns.
[ 222.854183] RTAI[usi]: enabled.
[ 222.926493] RTAI[math]: loaded.
[ 223.390314] RTAI[math]: unloaded.
[ 223.439451] SCHED releases registered named ALIEN RTGLBH
[ 223.468371] RTAI[malloc]: unloaded.
[ 223.568018] RTAI[sched]: unloaded (forced hard/soft/hard transitions: traps 0, syscalls 0).
[ 223.572381] I-pipe: Domain RTAI unregistered.
[ 223.572460] RTAI[hal]: unmounted.




Thanks
Jon
Last Edit: 13 May 2011 20:51 by jhtitan.
More
13 May 2011 21:23 #9794 by PKM
PKM replied the topic: Re:Second EMC2 config question
INIFILE=/home/emc/emc2/configs/Hot Wire/Hot Wire.ini

That seems to be the key. Just try removing spaces.
More
13 May 2011 21:26 #9795 by jhtitan
jhtitan replied the topic: Re:Second EMC2 config question
LOL ok that was it, Thanks!!!

Can't believe thats all it was lol, now to get a wire hooked up and see if it will work like I think it should :)


Jon
Time to create page: 0.059 seconds
Powered by Kunena Forum