Mesa 7i76e with G540

More
07 May 2018 01:18 #110306 by jpvonoy
Mesa 7i76e with G540 was created by jpvonoy
Hello,

I have a 3 axis router driven by 4 steppers (2 in tandem on the long axis). Using a Gecko G540 to drive the steppers. The machine was working fine using the parallel port to drive the G540.

With the 7i76e installed, and having run Pncconf, I'm getting super slow movement in the Z and X, in the wrong direction. So slow, it's barely perceptible, just clicking along. The Y axis doesn't seem to be moving at all.

From the reading I've done, I'm thinking the step and direction timing settings are wrong. I tried setting them to higher values, but it's still not working. Any ideas what I should try?

I also read that the G540 doesn't really have 10x micro-stepping, so I'm not sure what to set the Scale value at? In Pncconf I chose the 10x micro-stepping option.

I'm attaching my hal and ini files.

I disabled the charge pump on the G540 just to try to get the motion working first. I've found the recommended charge pump setup on other threads here. I'll add that in later.

Thanks for the help,
Jeremy
Attachments:

Please Log in or Create an account to join the conversation.

More
07 May 2018 02:02 #110307 by PCW
Replied by PCW on topic Mesa 7i76e with G540
The default velocity is pretty slow (~8 mm/second)
What is you screw pitch?

The G540 should be OK with about 2.5 usec timings

How is the g540 connected to the 7I76E?

(the 7I76E is a somewhat odd choice to drive a G540, a 7I92 would normally make more sense since the G540 has an integrated parallel port type breakout)

Please Log in or Create an account to join the conversation.

More
08 May 2018 00:45 #110359 by jpvonoy
Replied by jpvonoy on topic Mesa 7i76e with G540
I see velocity settings under DISPLAY, TRAJ, AXIS, and JOINT. Do they all need to match each other? I'll have to try adjusting them. To test the machine, I'm jogging it and using the slider to increase the velocity up to the max. When set to around 300 to 400 mm/min on the slider, I'm getting maybe 1mm/s movement on the Z axis, and less on the X. When I increase the slider to faster settings there is no movement at all, or imperceptible. And the direction is wrong on both X and Z when they do move.

The X and Y screw pitch is 10 mm, and Z is 4 mm.

I just quickly tried setting the 4 timing values to 2500 with no improvement, then tried adjusting the STEP_SCALE for no microstepping, which also didn't help.

I'll have to triple check my wiring to be sure I didn't miswire, but this is what I intended:
G540 DB25 to 7i76e TB2
2 - 3
3 - 5
4 - 9
5 - 11
6 - 21
7 - 23
8 - 15
9 - 17

Do I need to connect the GND pins on TB2 1, 7, 13, and 19?

I chose the 7176e because I want to use it with both the G540 and Leadshine drivers, as well as other future upgrade plans. I'm building another prototype machine with Leadshine drivers and want to be able to use the 7i76e to test that machine as well.

Please Log in or Create an account to join the conversation.

More
08 May 2018 01:49 #110361 by jpvonoy
Replied by jpvonoy on topic Mesa 7i76e with G540
I forgot to mention, I'm using LinuxCNC 2.8.

I just tried updating my ini to set all default velocities to match each other, with Max set to 160 and Accel to 320.

I also continuity checked all the connections between the 7i76e and g540. They match what I posted above.

Please Log in or Create an account to join the conversation.

More
08 May 2018 02:30 #110362 by PCW
Replied by PCW on topic Mesa 7i76e with G540
You _must_ connect the 7I76E ground pins to the G540 ground pins (G540 DB25 pins 18 through 25)
The following user(s) said Thank You: jpvonoy

Please Log in or Create an account to join the conversation.

More
08 May 2018 13:14 #110378 by jpvonoy
Replied by jpvonoy on topic Mesa 7i76e with G540
Thanks! Connecting those grounds fixed the motion problems. Now I need to invert the direction. I remember reading another post about that, I'll do a search.

Please Log in or Create an account to join the conversation.

More
12 May 2018 18:17 #110615 by jpvonoy
Replied by jpvonoy on topic Mesa 7i76e with G540
Just to provide some closure for those who read this in the future. I noticed Pncconf has a checkbox to invert the direction. This changed the sign of the SCALE value in the ini file. So, you could just manually edit your ini file and add a negative sign before the scale value for each axis.

Alternately, I read you can use ".invert_output" to change the sign of the direction parameter in the hal file. I didn't try that method, but other threads here discuss it.

I also setup the charge pump. Using Pncconf, I enabled the 5th stepgen on the 7i76e and selected Charge Pump from the drop down menu. To connect it to the G540 I ran a wire from the G540 (DB25 - pin 16) to the 7i76e (TB3 - Pin 3). That is the STEP4+ signal. I tied in TB3 - pin 1 with the other stepgen grounds (TB2 - pins 1,7,13,19).

Please Log in or Create an account to join the conversation.

More
18 Dec 2018 22:52 #122584 by yeltrow
Replied by yeltrow on topic Mesa 7i76e with G540
Hello -- I plan to run a machine with the G540 (a zenbot NC router). I would LOVE IT if you could send me a link to file share or something with your config files in it so that I could be up and running quickly. I know how much work this can be and would SO appreciate the shortcut. ALSO -- Would it be possible for you to show how you connected everything together? A few quick pics would be fine. I can work out the details if needed. I can make up all sorts of wacky cables to make this happen, but I am hoping that you came up with something simple and clever. Thank you very much!

Please Log in or Create an account to join the conversation.

More
21 Dec 2018 04:12 #122674 by yeltrow
Replied by yeltrow on topic Mesa 7i76e with G540
I have started a new thread for this specific machine here.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.091 seconds
Powered by Kunena Forum