Machinekit PnCConf

More
22 Dec 2018 22:26 #122761 by keefkontrol
Hey All,

I am a machinekit user. I am just getting started with my system (3 joint gantry, DM556 drivers, Mesa 7i76e, and an Intel J5005 running rt-patched stretch)
I have the card communicating via ping & get the correct mesaflash readhmi output. When I start pncconf with my vanilla machinekit build, the 7i76e is not available as a configuration option. My questions are twofold -

1) Does anyone have a quick solution in order to get up and running? Here BigJohnT mentions building a configuration based off of 5i25/7i76 and modifying. What would be the required changes?

2) Would it be worth it to trying to copy the linuxcnc versions and put them in their respective directories? What would be the proper way of updating the mk pncconf script to support the 7i76e out-of-the-box?

Thanks guys. I really appreciate all the help and support. I've always dug the tech community of open source software.

Please Log in or Create an account to join the conversation.

More
23 Dec 2018 14:34 #122782 by tommylight
Replied by tommylight on topic Machinekit PnCConf
If i remember correctly:
at the "loadrt hm2_pci......" has to be changed to "hm2_eth........" and the correct ip board address has to be added, and maybe all the references to 5i25.0.7i76 something to 7i76e, but i am not sure about the last part, it was nearly 2 years ago.

Please Log in or Create an account to join the conversation.

More
28 Dec 2018 18:46 #123028 by keefkontrol
Replied by keefkontrol on topic Machinekit PnCConf
I managed to get the linuxcnc version of pncconf to running by playing with the python module paths. I got it to run but none of the test windows worked, which was a real bummer. I also couldn't get the ini file to start via machinekit once the wizard configuration was complete :(
machinekit@debian:~/linuxcnc/configs/plasma_7i76e$ machinekit plasma_7i76e.ini
MACHINEKIT - 0.1
Machine configuration directory is '/home/machinekit/linuxcnc/configs/plasma_7i76e'
Machine configuration file is 'plasma_7i76e.ini'
Starting Machinekit...
rtapi_msgd command:  /usr/libexec/linuxcnc/rtapi_msgd --instance=0 --rtmsglevel=1 --usrmsglevel=1 --halsize=524288
rtapi_app command:  /usr/libexec/linuxcnc/rtapi_app_rt-preempt --instance=0
io started
halcmd loadusr io started
plasma_7i76e.hal:6: insmod failed, returned -1:
rtapi_app_main(motmod): -1 Operation not permitted

I'm new to linuxcnc but it appears that the kernel is not being recognized as real time capable?
The kernel has the preempt patch applied and is verified through uname.

I also tried launching the axis.ini file and while it seemed to initiate, no GUI windows appeared...

Please Log in or Create an account to join the conversation.

More
28 Dec 2018 21:22 #123037 by rodw
Replied by rodw on topic Machinekit PnCConf
You are not clear if you are running PREEMPT_RT kernel the Mesa ethernet cards require. What does uname say?

Also the 7i76e is supported in PNCCONF. I know this as I tested it for Chris Morley who wrote PNCCONF. It certainly works in master branch. I thought he pushed it back to V 2.7. You may need to edit the IP address in your hal file.

But if you are trying to use LinuxCNC configs with Machinekit, you are not going to get support here. This is for Linuxcnc.

Please Log in or Create an account to join the conversation.

More
28 Dec 2018 23:38 #123042 by cmorley
Replied by cmorley on topic Machinekit PnCConf
Rod is right. I have never done any work with machinekit for Pncconf.
I doubt they continued development for it.
I doubt that it would help much as AFAIK machinekit loads configs very differently.
They should probably remove it ( It's actually my intention in linuxcnc too)

Sorry

Chris M

Please Log in or Create an account to join the conversation.

More
29 Dec 2018 16:15 #123099 by pl7i92
Replied by pl7i92 on topic Machinekit PnCConf
you may see hat the line 6 in the HAL is saying to do

then you get a better impression on how the error is about

loadrt hostmot2
loadrt hm2_eth board_ip="10.10.10.10" config="firmware=hm2/7i76/7i76e.BIT num_encoders=1 num_pwmgens=0 num_stepgens=2 sserial_port_0=00xxxx"
setp hm2_7i76e.0.watchdog.timeout_ns 5000000

Please Log in or Create an account to join the conversation.

More
31 Dec 2018 13:24 #123200 by andypugh
Replied by andypugh on topic Machinekit PnCConf
It makes no sense to use anything in the "config=" string with a 7i76E. Just remove that. The only useful thing it can do is change the sserial mode.

Are you sure that 10.10.10.10 is correct? can you ping the card?

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.081 seconds
Powered by Kunena Forum