7i96 pncconf issue?

More
07 Feb 2021 19:50 #197947 by Bearfood
7i96 pncconf issue? was created by Bearfood
In the pncconfig tool I can use the test button and control my x axis but as soon as I exit the test to move onto Y I get an error and the FPGA LED lights red on the 7i96 controller.

Any thoughts?

Please Log in or Create an account to join the conversation.

More
07 Feb 2021 20:49 - 07 Feb 2021 20:49 #197952 by PCW
Replied by PCW on topic 7i96 pncconf issue?
I would probably test the axis with LinuxCNC rather than pncconf

It may be that pncconf violates real time when switching between axis
(the red light indicates a watcdog timeout)

Also pncconf issues should be posted to the pncconf section
Last edit: 07 Feb 2021 20:49 by PCW.
The following user(s) said Thank You: Bearfood

Please Log in or Create an account to join the conversation.

More
08 Feb 2021 16:42 #198017 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
Tried it in LinuxCNC and have similar results. Y and Z which are both dual stepper don't move or try to move at all. I've gone through the wiring to make sure that the coils match and everything looks fine from that perspective. Not sure what I'm doing wrong. X is fine (single motor)

Please Log in or Create an account to join the conversation.

More
08 Feb 2021 16:52 #198019 by tommylight
Replied by tommylight on topic 7i96 pncconf issue?
Moved to PnCConf section as requested.

Please Log in or Create an account to join the conversation.

More
08 Feb 2021 16:59 #198021 by PCW
Replied by PCW on topic 7i96 pncconf issue?
Can you post your hal and ini files?

Please Log in or Create an account to join the conversation.

More
09 Feb 2021 02:32 #198112 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
Here's the hal and ini files.

I don't see any error logs or files.
Attachments:

Please Log in or Create an account to join the conversation.

More
09 Feb 2021 02:34 #198114 by cmorley
Replied by cmorley on topic 7i96 pncconf issue?

In the pncconfig tool I can use the test button and control my x axis but as soon as I exit the test to move onto Y I get an error and the FPGA LED lights red on the 7i96 controller.

Any thoughts?


What is the error posted?

Please Log in or Create an account to join the conversation.

More
09 Feb 2021 02:44 #198116 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
I don't get the error anymore (for the life of me I can't recall the fix to that) just the light and someone said the light was because pncconf violated the real-time part of the kernel which generated the light. The problem I have right now is that X (single motor) moves but Y (dual Motor) and Z (dual motor) will not even attempt to move. I thought the 2 were linked but sadly no.

Please Log in or Create an account to join the conversation.

More
09 Feb 2021 04:28 #198118 by PCW
Replied by PCW on topic 7i96 pncconf issue?
How are you commanding the axis to move?

I dont see any homing setup so would not expect axis jogs to be functional

Please Log in or Create an account to join the conversation.

More
09 Feb 2021 14:42 #198147 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
I'm able to use the jog function on the x axis after I home each of the joints in LinuxCNC or the Test Axis in PNCconf. Just can't get Y & Z to do something similar.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.079 seconds
Powered by Kunena Forum