7i96 pncconf issue?

More
14 Feb 2021 22:13 - 14 Feb 2021 22:14 #198863 by PCW
Replied by PCW on topic 7i96 pncconf issue?
One suggestion: wire the drives as single ended rather the differential
that is, wires all drives DIR-, STEP- to 7I96 ground rather than 7I96
DIR-, STEP-

Also is 12V enough for the drives? Might be pretty close to their minimum voltage.
Last edit: 14 Feb 2021 22:14 by PCW.

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 22:35 #198871 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
On the 7i96 X is wired to Step4. If I move the wire block from Step 3 to Step 4 then another axes motor moves. This means that the wires from the 7i96 to the drivers is good.

I must be missing something with the 7i96 card or the 7i96 itself is bad or this really is software config that I'm somehow messing up. I can get each motor to move by swapping ports on the 7i96 with the x axis port step4.

I have 1 X, 2 Y and 2 Z motors. It's the duals (X, Z)I can't get to work. My apologies if this is getting annoying.

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 22:37 #198872 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
drivers need 9 to 36VDC. I'll try reworking it to be 3 singles and see what happens.

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 22:57 #198875 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
Tried wiring 3 axis only using ports Step 0 - 2 and nothing works. If I take one of the stepper wire blocks over to Step4 it works.

Step4 works every time on the board. Is there a way to see if there are any issues with the board? Diagnostic tool?

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 23:14 - 14 Feb 2021 23:19 #198877 by PCW
Replied by PCW on topic 7i96 pncconf issue?
If only step4/dir4 works and step/dir 0,1,2,3 don't work and they are set up identically in hal
that suggests that the driver chips that connect to step/dir outputs 0,1,2,3 have been
damaged.

You can verify that outputs work by measuring the step+ and step-
and dir+ and dir- outputs when linuxCNC is running and after you have exited LinuxCNC.

With no load, these outputs should be very close to 5V in one state and close to 0V in the other
Last edit: 14 Feb 2021 23:19 by PCW.

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 23:19 #198879 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
Is there something I have to do to configure the card with Mesaflash or something?

Please Log in or Create an account to join the conversation.

More
14 Feb 2021 23:22 #198881 by PCW
Replied by PCW on topic 7i96 pncconf issue?
This would not be a firmware issue

Please Log in or Create an account to join the conversation.

More
15 Feb 2021 00:24 #198885 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
Okay, my multimeter stopped working a few months back so I now have one on order. I should really have one anyways.

Thanks for all the help! I really appreciate it!

I'm not sure I understood your earlier comment on DIR- and STEP- to 7196 ground. Do you have a diagram I could refer to?

Please Log in or Create an account to join the conversation.

More
15 Feb 2021 22:14 #198993 by Bearfood
Replied by Bearfood on topic 7i96 pncconf issue?
The Multimeter didn't take long to get here. Here are the results.

Linuxcnc on, card powered
Step1 =4.38v
Step2 = 4.38v
Step3 = 4.46v
Step4 = 4.47v
Step5 = 5.1v

Lunuxcnc off but card powered
Step1 = 4.38v
Step2 = 4.38v
Step3 4.46v
Step4 = 4.47v
Step5 = 3.9v

So all Axis are the same except Step5 which is the working step. Not sure where to go from here.

Please Log in or Create an account to join the conversation.

More
16 Feb 2021 00:34 #199002 by PCW
Replied by PCW on topic 7i96 pncconf issue?
Can you check the stepN+ and stepN- to ground?

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.109 seconds
Powered by Kunena Forum