Z axis travel/ Program exceeds machine maximum on axis Z

More
26 Mar 2021 19:34 #203742 by Bearfood
Perhaps I figured it out. If I hit touch off and enter 1" z height then the machine drops to 1 inch and starts running through the cuts. This is great!

Then if I reset home to be 0,0,0 restart and touch off to 1" I again get the same error that my z exceeds the negative limit.

How is the z typically set up and what is the typical home position?

Please Log in or Create an account to join the conversation.

More
26 Mar 2021 20:22 #203747 by Clive S

Perhaps I figured it out. If I hit touch off and enter 1" z height then the machine drops to 1 inch and starts running through the cuts. This is great!

Then if I reset home to be 0,0,0 restart and touch off to 1" I again get the same error that my z exceeds the negative limit.

How is the z typically set up and what is the typical home position?


According to your hal file Z is showing that you have two joints BUT you only have one joint for Z in the ini file.!!

How are you homing. It seems you don't have home switches. If this is a gantry machine it would be good to have home switches so that you can auto square the gantry.

The Z is normally home at the top with Z- going down.

More info on the machine wound help

Please Log in or Create an account to join the conversation.

More
26 Mar 2021 20:54 #203750 by Bearfood
It's a lowrider2 if that helps. www.v1engineering.com/lowrider-cnc/

I have not set up limit switches yet mostly because I haven't figured out how to mount them. They're on my list of things to figure out and do.

The machine is 48"X, single motor on GT2 10mm belt. Y is 48" dual motor on gt2 10mm belts and z is 5" dual motor driving lead screws.

Controller is a Mesa 7i96 attached to TB6600's for each of the joints.

I'll reset home to be at 5" for the z axis for now.

Please Log in or Create an account to join the conversation.

More
27 Mar 2021 22:12 #203849 by andypugh
It generally works best to have the top of travel for the Z axis as zero (in machine coordinates) and then have the bottom of travel a negative number.

So, Z axis max limit is zero, and minimum limit is negative.

Apart from any other reasons, lots of CAM packages like to put an absolute move to Z=0 at the start of the G-code. This is bad if z=0 is under the top of the table.

Please Log in or Create an account to join the conversation.

More
28 Mar 2021 15:52 #203910 by Bearfood
Thanks. So I've put home for z as 5 inches in the air and allowed -5 travel. I know I need to set limit switches but how do I set home without for now? When I start Linuxcnc I have to home all the joints but I can't seem to move them prior to homing them.

Once I get the limit switches set up how do I execute an auto home?

Please Log in or Create an account to join the conversation.

More
28 Mar 2021 16:11 - 28 Mar 2021 16:21 #203913 by Aciera
This has been pointed out more than once already:
You have these lines in your HAL, setting parameters to values that are supposedly in your INI [JOINT_4] section
#*******************
#  Tandem AXIS Z2 JOINT 4
#*******************

setp   pid.z2.Pgain     [JOINT_4]P
setp   pid.z2.Igain     [JOINT_4]I
setp   pid.z2.Dgain     [JOINT_4]D
setp   pid.z2.bias      [JOINT_4]BIAS
setp   pid.z2.FF0       [JOINT_4]FF0
setp   pid.z2.FF1       [JOINT_4]FF1
setp   pid.z2.FF2       [JOINT_4]FF2
setp   pid.z2.deadband  [JOINT_4]DEADBAND
setp   pid.z2.maxoutput [JOINT_4]MAX_OUTPUT

Yet in your INI there is no [JOINT_4] section at all. So I my opinion this config should not even load but fail with an error message.

Are you sure you posted the correct files?

[edit]
This hal and ini file combination would fail to load and give an error:
"INI variable [JOINT_4]P not found"
So these cannot be the correct files.
Last edit: 28 Mar 2021 16:21 by Aciera.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.072 seconds
Powered by Kunena Forum