LinuxCNC 2.9 RPi - PNCconf error

More
12 Jul 2022 21:44 #247191 by Gifix
Hello,

I faced a problem when trying to configure linuxcnc for MESA 7i96S, after reaching External Controls tab at PNCconf I cannot go further because of this error with GS2.
 

 
Attachments:

Please Log in or Create an account to join the conversation.

More
13 Jul 2022 03:33 #247209 by cmorley
try running from a terminal like this:

LC_ALL=C pncconf

Sometimes different languages present problems.

Please Log in or Create an account to join the conversation.

More
13 Jul 2022 07:47 #247214 by Gifix
Unfortunately this didn't work. I've changed system language to english but that either don't work.

Still the same error.

Please Log in or Create an account to join the conversation.

More
13 Jul 2022 12:01 #247228 by tommylight
Did you try changing locale to UTF8 ?

Please Log in or Create an account to join the conversation.

More
13 Jul 2022 19:48 #247248 by Gifix
Yes, still the same error... :(

Please Log in or Create an account to join the conversation.

More
15 Jul 2022 09:50 #247361 by Gifix
I've manage to go through configuration in pncconf without error, by disabling advanced options pages at the beginning of configuration.

Currently I am running system on M.2 ssd connected via usb, so I made fresh system on sd card and it work without problem. Later I'll try to make fresh system on ssd and see if then it will work.

Please Log in or Create an account to join the conversation.

More
28 Mar 2023 23:02 #267738 by mor
Any suggestions for resolving this issue without disabling Advanced Options? I'm trying to use "pncconf -d debug" and need the advanced options to enable board discovery.

Thanks in advance!

Please Log in or Create an account to join the conversation.

More
29 Mar 2023 00:54 #267744 by phillc54
I have tried PNCconf on 2.9 and I am unable to duplicate this error. I haven't changed anything from the defaults other than enabling Show Advanced Option Pages

Please Log in or Create an account to join the conversation.

More
29 Mar 2023 00:56 #267745 by mor
I've tried both 2.9 and 2.10 and always have the same issue as the OP.

I'm using RPI 4 with 64-bit PREEMPT_RT and built 2.9 from source.

Please Log in or Create an account to join the conversation.

More
29 Mar 2023 01:02 #267746 by phillc54
I tried on a Debian 11 arm64 VM (iMac host) with 2.9 built from source. I have a RPI 64 somewhere here, I find it and give it a try.
The following user(s) said Thank You: mor

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.107 seconds
Powered by Kunena Forum