Rectangle probe.ngc

12 Sep 2013 04:58 #38679 by charrier
charrier created the topic: Rectangle probe.ngc
I install in in file the ngc. Rectangle probe in my ini file. I find this ngc in the ncfiles example of linuxcnc disk

The subroutine is on the display of axis.

i modify the value of x min x Max. Incrément. Y min y Max incrément z secure z Max MM. And vélocity, and i finalise, the gcode appear in the diisplay of axis but when i laught the gcode axis send an error

Dont find M code. ,?,,??? What Is It. In my. Config. Folder. I just find m 119


12 Sep 2013 14:27 #38684 by ArcEye
ArcEye replied the topic: Rectangle probe.ngc

The M code file has to be

1) executable ( chmod 755 filename )
2) the same case ( if you call M101 the file must be called M101 not m101 )
3) in the directory held in your ini file under PROGRAM_PREFIX=

12 Sep 2013 20:20 #38699 by BigJohnT
BigJohnT replied the topic: Rectangle probe.ngc
13 Sep 2013 12:07 #38744 by charrier
charrier replied the topic: Rectangle probe.ngc
Hi And thanks It s running

Best regards

26 Mar 2017 01:08 #90276 by rbarry1068
rbarry1068 replied the topic: Rectangle probe.ngc
I am getting a similar error when trying to run the Rectangle_Probe.ngc program. It shows up fine the AXIS gui, I enter my parameters, it generates a graphic of the probe run, but when I attempt to execute it, I get an error "UNKNOWN COMMAND M110". I looked in the rectangle_probe.ngc file and found " M110 (axisui.notifications-clear)" . After getting that error, I tried to execute again and now don't get any error, but the probe does not progress.

Any ideas?
26 Mar 2017 01:12 #90278 by rbarry1068
rbarry1068 replied the topic: Rectangle probe.ngc
I looked for an M110 command on my system, but can't find one. This used to work fine in older versions of LinuxCNC. Do I need to create an M110 Python script of some sort?
27 Mar 2017 10:37 #90343 by andypugh
andypugh replied the topic: Rectangle probe.ngc
M110 is in the user-defined M-codes range (M100-M199). When the G-code contains any of those then the system looks for an executable file of the same name, and tries to run it.

You will need to find out what that M110 file was in the original config.
01 Apr 2017 17:05 #90717 by rbarry1068
rbarry1068 replied the topic: Rectangle probe.ngc
OK, I found an M110 command in the code repository:
# Clear axis info notifications
# use in gcode subroutines and/or connect to pushbutton

# M1nn files must exist _before_ starting emc
# or in a dir specified by [RS274NGC]USER_M_PATH

# the pin for axisui.notifications-clear-info is in emc-2.4pre
# using an earlier version will print error to stdout

halcmd setp axisui.notifications-clear-info 1
sleep .100 ;# requires a sleep that does <1
halcmd setp axisui.notifications-clear-info 0

# if a M1nn command fails and its script exits with nonzero status,
# the gcode program exits.  So always exit 0, and make sure
# the M1nn command prints a message in order to keep on going.
exit 0

So then I created an M110 file in linuxcnc/nc_files/examples/, then set it have executable privs for all users. I thought, OK, I've got this fixed now, but NOOOO. Still have the same error when executing rectangle_probe, "unknown m code used: M110" .

What am I missing now??
02 Apr 2017 00:19 #90744 by rbarry1068
rbarry1068 replied the topic: Rectangle probe.ngc
I also put a copy of the M110 command file in the same directory as my machine.ini file, still no joy. I noticed that I could set the "wait for start" value in rectangle_probe to 0 and it would at least run, but I did not get any values in the probe_result.txt file, just zeroes.
02 Apr 2017 01:00 #90750 by rbarry1068
rbarry1068 replied the topic: Rectangle probe.ngc
ArcEye was right!! You MUST have the M110 command file in the directory referenced by the PROGRAM_PREFIX variable of your machine.ini file. I am now probing again.
Moderators: Rick G
Time to create page: 0.080 seconds
Powered by Kunena Forum