Call external subroutine not working in recent versions of LCNC

More
07 Feb 2019 18:56 - 07 Feb 2019 19:38 #125941 by shipmodeller
Ok.. I do have an issue here.
I am running Axis 2.8.0 pre1-4546
I have a subroutine to zero the z axis, and placed it into the ncfiles section
When I boot up, and home, I try to run the HAL button that I have tied to it, but it doesn't work
I can use the MDI window and execute the subroutine ( o<toolchange3> call )
AFTER I execute the subroutine via MDI window, I can now use the HAL Button to zero the z axis... ok, weird ...
I now load a program from the share
I can no longer zero the axis via the MDI button OR the HAL Button ..

All this worked fine before I updated to the new LinuxCNC last year. I had to update because I have tied X axis motors, and the update worked well for that. So, If I load the zero routine manually from the files.. it works...

Can anybody give me ANY lead on what to do? It doesn't appear to follow a rights issue, but maybe????? And what documentation if any could I supply here????

File Attachment:

File Name: my-mill_20...07-2.ini
File Size:3 KB


shipmodeller@LinuxCNC:~/linuxcnc/configs/my-mill$ uname -r
3.4-9-rtai-686-pae
shipmodeller@LinuxCNC:~/linuxcnc/configs/my-mill$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 7.11 (wheezy)
Release: 7.11
Codename: wheezy
Attachments:
Last edit: 07 Feb 2019 19:38 by shipmodeller.
More
08 Feb 2019 07:28 #125977 by andypugh
When did it stop working? I wonder if this fix has broken something?
github.com/LinuxCNC/linuxcnc/issues/455
More
08 Feb 2019 13:51 - 08 Feb 2019 14:33 #125999 by shipmodeller
It was acting "off" last year when I loaded up the new Axis, but then I had a few months off while playing with my new 100W Laser, then travel, holidays then surgery. When I got back on it this month, it had one or two more updates, than I started to really use it again. That's when I noted this problem for sure, and had time to reproduce it. It is quite reproducible. I am willing to try whatever, it is almost unusable if I have to restart it every time I do a tool change. It almost looks like a file rights issue.. but then again.. I am not familiar with the source.
Last edit: 08 Feb 2019 14:33 by shipmodeller.
More
08 Feb 2019 13:56 #126000 by shipmodeller
I did a quick look at your link.. I didn't do any editing.. The steps in my note are the only things I need to do to reproduce it from startup. I don't want to go backwards on LinuxCNC because of the dual drives on the X axis.. it works great on the new versions, but this process of having to reload on each tool change is bad. And yes, I could manually set the bit each change.. and I have.. but come on.. this is a defect of some kind. Thank you.
How can I proceed to help solve this?
More
10 Feb 2019 20:22 #126171 by andypugh

shipmodeller wrote: I did a quick look at your link.. I didn't do any editing.. The steps in my note are the only things I need to do to reproduce it from startup.


I wasn't suggesting that you had edited the file. I was speculating if the fix for the editing problem might have broken something else.
More
10 Feb 2019 21:38 #126174 by andypugh
I have tried to create a simulated machine with a HAL button and an ngc routine triggered by an MDI_COMMAND and it all works.

Maybe you are using a different "HAL Button". Can you explain how your O-sub routine is linked to HAL?
More
11 Feb 2019 17:09 #126206 by shipmodeller
Pretty sure I supplied those files before .. and remember.. what you "simulated" did not seem to address the issue.. but I thank you for your effort. I have put up my ini file, and the hal files for you to look at. I don't know what is going on, I suspect rights issues... I can load those files via midi all day long, UNTIL I load up another file, then I lose it. So, the main question I will pose again, should I push this as a defect, and if so, what documentation should I upload? Very big thanks...

Right now, I am getting around all this by loading the toolchange program manually for each tool I need. PIB.. :-)

File Attachment:

File Name: custom.hal
File Size:1 KB

File Attachment:

File Name: custom_postgui.hal
File Size:2 KB

File Attachment:

File Name: my-mill_20...2-11.hal
File Size:6 KB

File Attachment:

File Name: my-mill_20...2-11.ini
File Size:3 KB
Attachments:
More
11 Feb 2019 20:41 #126218 by andypugh
Does the "metal touchoff" work properly?
One difference I do see is that there is a classicladder interlock on the toolchange3 button, that seems to be checking mode.is-mdi

What happens if you switch to the MDI tab, _don't_ run an MDI command and then press the button?
More
11 Feb 2019 20:51 #126219 by shipmodeller
Well, the metal touchoff .. was working in the prior release.. yes. ( 0 added for offset.. ) So when I did wood, the .625 was added. When I did metal, nothing was added to touch zero.

So.. the number 1 issue as reflected in my original post is:

1: From boot, I can go tot he Midi panel and execute the o<xxx> call tool change without problem.
2: The button doesn't seem to work till i do that .
3: But, once I load a GCODE file into the system, the midi command won't find the toolchange file anymore and the button no longer functions.
More
11 Feb 2019 21:02 #126220 by andypugh
Can you do a quick test? Open a Halmeter and look at halui.mdi-command-00 and make sure that it does go "true" when you press the button in the scenario where you are seeing a problem?
Time to create page: 0.104 seconds
Powered by Kunena Forum